Как пользоваться планами обмена в 1С?

Здравствуйте.
Только недавно изучаю 1С:Предприятие. Подскажите, пожалуйста, как пользоваться планами обмена? Необходимо выгрузить из справочника добавленных и измененных контрагентов. По примеру создал план обмена и обработку. В обработке написал код

&НаСервереБезКонтекста
Процедура Команда1НаСервере()
	Узел = ПланыОбмена.ПланОбмена1.НайтиПоКоду("DEMO");
	
	ИмяВременногоФайла = ПолучитьИмяВременногоФайла("xml");
	
	Запись = Новый ЗаписьXML();
	Запись.ОткрытьФайл(ИмяВременногоФайла);
	Запись.ЗаписатьОбъявлениеXML();
	
	ЗаписьСообщения = ПланыОбмена.СоздатьЗаписьСообщения();
	
	ЗаписьСообщения.НачатьЗапись(Запись, Узел);
	ЗаписьСообщения.ЗакончитьЗапись();
	
	Запись.Закрыть();
КонецПроцедуры

&НаКлиенте
Процедура Команда1(Команда)
	Команда1НаСервере();
КонецПроцедуры


но при выполнении кода получаю ошибку
{Обработка.Обработка1.Форма.Форма.Форма(14)}: Ошибка при вызове метода контекста (НачатьЗапись)
ЗаписьСообщения.НачатьЗапись(Запись, Узел);
по причине:
Код узла не может быть пустым

Что я делаю не так?
  • Вопрос задан
  • 1091 просмотр
Решения вопроса 1
fosihas
@fosihas
Автоматизации учета на 1С.
Процедура Выгрузка(Элемент) 
 
        Путь = "c:\"; //реальный путь к каталогу, в котором создаются файлы 
 
        ЗаписьXML = Новый ЗаписьXML(); 
        ЗаписьXML.ОткрытьФайл(Путь + "выгрузка.xml"); 
        Узел = ПланыОбмена.Поставка.НайтиПоКоду("Маг1"); 
 
        ЗапСообщения = ПланыОбмена.СоздатьЗаписьСообщения(); 
        ЗапСообщения.НачатьЗапись(ЗаписьXML, Узел); 
 
        Выборка = ПланыОбмена.ВыбратьИзменения(Узел, ЗапСообщения.НомерСообщения); 
 
        Пока Выборка.Следующий() Цикл 
               Данные = Выборка.Получить(); 
 
               Если ТипЗнч(Данные) = Тип("ДокументОбъект.РеализацияТоваров") Тогда 
                       ВыгрузкаРеализации(ЗаписьXML, Данные); 
        
               Иначе // все остальные объекты 
                       ЗаписатьXML(ЗаписьXML, Данные); 
               КонецЕсли; 
        КонецЦикла; 
 
        ЗапСообщения.ЗакончитьЗапись(); 
        ЗаписьXML.Закрыть(); 
 
КонецПроцедуры
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы