@ropblHbl4

Почему медленно грузится Win 7 с SSD (AHCI, SATA III)?

Всех приветствую, вопрос следующий:
довольно медленно грузится Win 7 (х64) с SSD: 30-40 сек. в AHCI режиме (SATA III), так же, как и в IDE.

С чего началось: после покупки SSD перенёс ОС с помощью Paragon Migrate OS to SSD 3.0,
загружаю - грузится по-быстрее, чем с HDD (~30 сек. против ~60), но не так быстро, как могла бы.

В БИОС-е переключил режим с IDE на AHCI, загружаю - лепестки символа Win 7 летят стремительно, аж дух захватываеть, но на середине процесса вылетаем в BSOD.

По совету из статьи на сайте Microsoft
https://support.microsoft.com/ru-ru/...the-boot-drive
переключился обратно в IDE, поставил параметр реестра
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci\Start
на 0,
после этого установился драйвер, перезагружаемся, включаем AHCI - винда грузится так же медленно, как при IDE.

Скорости у диска, вроде как, хорошие (по замерам CrystalDiskMark):
Sequential Read (Q= 32,T= 1) : 481.259 MB/s
Sequential Write (Q= 32,T= 1) : 475.491 MB/s
Random Read 4KiB (Q= 32,T= 1) : 262.498 MB/s [ 64086.4 IOPS]
Random Write 4KiB (Q= 32,T= 1) : 226.921 MB/s [ 55400.6 IOPS]
Sequential Read (T= 1) : 430.990 MB/s
Sequential Write (T= 1) : 451.022 MB/s
Random Read 4KiB (Q= 1,T= 1) : 29.466 MB/s [ 7193.8 IOPS]
Random Write 4KiB (Q= 1,T= 1) : 69.924 MB/s [ 17071.3 IOPS]

Test : 1024 MiB [C: 53.2% (59.4/111.7 GiB)] (x5) [Interval=5 sec]
Date : 2017/03/19 14:40:45
OS : Windows 7 Ultimate SP1 [6.1 Build 7601] (x64)

Win 7 ставит ему 7.9.

Обновил железо (всё, кроме дисков и БП), заметил особенность: стало секунд 10 ждать, когда загрузка винды уже пошла и надпись появилась, но Win-лепестки ещё не показались.

Действия в попытках решить вопрос:
- Установил Microsoft Fix It [видимо, ставит в реестре то же, что я до этого уже поставил вручную]
- Ставил различные драйверы на "IDE ATA/ATAPI контроллеры": стандартные от винды (поставились после смены параметра в реестре), от материнки разные версии...
- Попробовал обновить драйвер на SSD [уже последняя версия]
- Откл. остальные HDD
- Попробовал другие разъёмы питания/SATA
- Попробовал отключить DevSleep [видимо, не отключается или он не виноват].

Может, кто-то сталкивался с подобным ?
Неужели остаётся только переустанавливать винду (или и это не поможет) ?
  • Вопрос задан
  • 9382 просмотра
Пригласить эксперта
Ответы на вопрос 4
Отформатируйте SSD и установите винду с нуля. Никаких проблем быть не должно.
Ответ написан
maaGames
@maaGames
Погроммирую программы
Не парься. Переустановишь винду, пол года будешь радоваться, а потом опять вернёшься к этим 30-40 секундам. Так что либо смирись, либо переустанавливай виндоус не реже раза в год.
С другой стороны, можешь радоваться, что ещё большей деградации скорости загрузки не будет скорее всего. У меня уже года три примерно с такой же скоростью грузится, а вот сразу после переустановки, да без драйверов, да без антивируса... Быстро было, в общем. Было, да прошло.
Ответ написан
@ropblHbl4 Автор вопроса
Итак, господа, увеличиваем уровень сложности:
переустановка винды не помогла оО
Грузится так же, с примерно тем же ожиданием вначале загрузки, только "Добро пожаловать" пока что чуть по-быстрее проскакивает.

Этот SSD не сразу понимает, что он супермэн, чтоли...
Или материнка ему это поздно объясняет...

Я вот не уверен, что SSD виноват,
на предыдущем железе у него хоть 1 быстрое поползновение было (самое первое, когда в BSOD улетел),
на новом - ни одного.

Или, может, я его плохо форматнул, может, надо было полное форматирование ?

А, вот ещё: есть на SSD микрораздельчик ~100 МБ, его я не трогал, может, там что-то засело ?..
Ответ написан
@LuchS-lynx
инженер-ПТО
Если хочется заморочиться, то можно поиграться, навроде как это описано в этой статье: https://geektimes.ru/post/106684/
а еще я бы потестил железо, в первую очередь мать, мало ли что и проверил заполненность SSD, некоторые модели проседают в скорости доступа, если диск забит под завязку.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы