Как настроить QoS для потоковых данных (видеоконференции) на mikrotik?

На совещаниях сотрудники используют видеоконференцсвязь zoom.us при этом наблюдаются провалы в скорости соединения и вести трансляцию и участвовать в переговорах становится затруднительно.
Интернет в офисе раздается с помощью роутера mikrotik rb2011UiAS-RM.
Вопрос в следующем, как настроить QoS с приоретизацией трафика этого приложения?
Буду рад и благодарен любым советам и ссылкам на статьи.
  • Вопрос задан
  • 3671 просмотр
Решения вопроса 1
sizaik
@sizaik
сисадмин, Витебск
Любой QoS состоит из двух частей.
1. Отмаркировать интересующий трафик в /ip firewall mangle. Тут вам нужно проанализировать соединения на zoom.us и понять, как именно туда/оттуда передаются данные. Анализировать можно по-всякому - через текущие соединения на том же микротике, через Wireshark, как вам удобнее. Ниже пример, как я маркирую трафик для RTP-соединений с голосовым провайдером:
// маркируем соединения
/ip firewall mangle
add action=mark-connection chain=prerouting connection-mark=no-mark dst-port=\
16384-16538 new-connection-mark=VOIP passthrough=no protocol=udp
// маркируем пакеты в этом соединении
add action=mark-packet chain=prerouting comment=VOIP connection-mark=VOIP \
new-packet-mark=VOIP passthrough=no

2. Создать правила приоритета для интересующего трафика. Это делается через очереди:
/queue tree
add name=queue1 parent=wan-interface priority=1 queue=default
add name=queue2 packet-mark=VOIP parent=queue1 priority=2 queue=default
add name=queue3 packet-mark=no-mark parent=queue1 priority=8 queue=default

Ну и еще несколько моментов:
  • Надо понимать, что эффективно управлять вы можете только исходящим трафиком. Входящие пакеты находятся в вашей зоне влияния, когда они уже пришли, поэтому с ними не имеет смысла что-либо делать. Если, конечно, нет задержек в локальной сети, что встречается редко.
  • Голосовая и видеосвязь критична к времени прохождения пакета. А т.к. zoom.us находится, судя по названию, за океаном, каждый пакетик по пути проходит много промежуточных устройств, на каждом из которых возможны задержки, которыми вы управлять никак не можете. Если вы устраиваете конференции с людьми из России - не лучше ли поискать что-то поближе? Если основная аудитория из США, тогда, конечно, придется терпеть.
Ответ написан
Пригласить эксперта
Ответы на вопрос 1
@DKarasev
На основе ответа выше и данных по портам с сервера Zoom:

/ip firewall mangle
add action=mark-connection chain=prerouting connection-mark=no-mark dst-port=3478-3479 new-connection-mark=VOIP passthrough=no protocol=udp
add action=mark-connection chain=prerouting connection-mark=no-mark dst-port=8801-8802 new-connection-mark=VOIP passthrough=no protocol=udp
add action=mark-connection chain=prerouting connection-mark=no-mark dst-port=8801-8802 new-connection-mark=VOIP passthrough=no protocol=tcp
add action=mark-packet chain=prerouting comment=VOIP connection-mark=VOIP new-packet-mark=VOIP passthrough=no

/queue tree
add name=queue1 parent=wan-interface priority=1 queue=default
add name=queue2 packet-mark=VOIP parent=queue1 priority=2 queue=default
add name=queue3 packet-mark=no-mark parent=queue1 priority=8 queue=default
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы