@Cirick

Возможно ли настроить соединение 3 провайдеров на циске 3845?

Сразу скажу что в цисках и их настройка я полный ноль)) но ситуация такая что вот надо «ИМ» и все тут)))
Ситуация в следующем.
В наличии Cisco 3550 и 3845.
Интерфейсы cisco 3550 c несколькими вланами в сети, vlan 1 – 1.1.1.1/24, vlan 2 - 2.2.2.2/24, vlan 3 – 3.3.3.3/24. Каждый влан это отдельная фирма со своими устройствами.
Интерфейс на cisco 3550 Gi0/24 ip 172.20.0.2 смотрит на Cisco 3845 Gi 0/0 ip 172.20.0.1
Маршруты примерно такие (почему примерно будет ниже):
ip default-gateway 172.20.0.1
ip route 0.0.0.0 0.0.0.0 172.20.0.1

на 3845 было одно подключение PPPoE, и все дружно и счастливо бегали за интернетом через одного провайдера.
Теперь ситуация поменялась, и каждая фирма хочет ходить через свое PPPoE соединение (некоторые хотят свой личный кабинет у провайдера, другие чтоб в интернет выходить с другого ip, и т.д). То есть:
Фирма 1 – vlan1 сеть 1.1.1.1/24 – должна соединяться PPPoE 1
Фирма 2 – vlan2 сеть 2.2.2.2/24 – должна соединяться PPPoE 2
Фирма 3 – vlan3 сеть 3.3.3.3/24 – должна соединяться PPPoE 3

На cisco 3845 Gi 0/1 смотрит в сторону провайдера
Так как провайдер будет один для всеx и логины уже получены, попробовал создать несколько PPPoE сессий на один интерфейс Gi 0/1 поличилось примерно так:
interface GigabitEthernet0/1
 description WAN
 no ip address
 duplex auto
 speed auto
 media-type rj45
 pppoe enable group global
 pppoe-client dial-pool-number 1
 pppoe-client dial-pool-number 2
 pppoe-client dial-pool-number 3
!
interface Dialer1
 ip address negotiated
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 1
 ppp authentication chap callin
 ppp chap hostname user@фирма_1
 ppp chap password PassworD
!
interface Dialer2
 ip address negotiated
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 2
 ppp authentication chap callin
 ppp chap hostname user@фирма_2
 ppp chap password PassworD
!
interface Dialer3
 ip address negotiated
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 3
 ppp authentication chap callin
 ppp chap hostname user@фирма_3
 ppp chap password PassworD
!

Все соединения проходят, провайдер их видит у себя.
А вот дальше я не понимаю как же настроить что бы при обращение с адресов 1.1.1.1/24 в интернет ходили через Dialer 1, с адресов 2.2.2.2/24 через Dialer 2, с адресов 3.3.3.3 через Dialer 3?

Облазил кучу форумов но ответа так и не нашел…

И еще немного информации.
1 Админы которые всем этим рулят сидят очень далеко и не охотно идут на встречу.
2 Доступа на Cisco 3550 у меня нет и не будет ,так Админы сказали :-) , дали только на роутер 3845. Мотивируя это тем что на 3550 сложные маршруты и менять их нельзя.

Вот так)
  • Вопрос задан
  • 1023 просмотра
Решения вопроса 1
ragent
@ragent
сетевой инженер
Cirick примерчик использования Policy-based routing:
создаем access-list:
access-list 101 permit ip 1.1.1.0 0.0.0.255 any
access-list 102 permit ip 2.2.2.0 0.0.0.255 any
access-list 103 permit ip 3.3.3.0 0.0.0.255 any

создаем route-map:
route-map pbr-inet permit 10
match ip address 101
set interface Dialer1 (или какой у Вас смотрит на isp1)
route-map pbr-inet permit 20
match ip address 102
set interface Dialer2
route-map pbr-inet permit 30
match ip address 103
set interface Dialer3

выпускаем в Интернет:
ip nat inside source route-map pbr-inet interface Dialer1
ip nat inside source route-map pbr-inet interface Dialer2
ip nat inside source route-map pbr-inet interface Dialer3

В конце т.к. policy-based routing использует source адрес для манипуляций, нужно применить policy на внутреннем интерфейсе:
interface GigabitEthernet0/0
ip policy route-map pbr-inet
Ответ написан
Пригласить эксперта
Ответы на вопрос 3
@John_Alban
Network/IDS engineer
Смотрите в сторону vrf - наименее затратный способ с точки зрения ресурсов. Делаете 3 vrf, к каждый из них вносите пару vlan/pppoe интерфейсов, плюс в каждом vrf прописываете свои маршруты по умолчанию.
Ответ написан
@throughtheether
human after all
А вот дальше я не понимаю как же настроить что бы при обращение с адресов 1.1.1.1/24 в интернет ходили через Dialer 1, с адресов 2.2.2.2/24 через Dialer 2, с адресов 3.3.3.3 через Dialer 3?
Поэкспериментируйте с Policy-based routing на 3845.

на 3550 сложные маршруты
Подразумевается catalyst? Интересные люди ваши админы.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
26 февр. 2021, в 05:09
3000 руб./за проект
26 февр. 2021, в 04:16
3000 руб./за проект
26 февр. 2021, в 01:40
1000 руб./за проект