@vitalyg

Как установить Percona-server 5.6 с ошибкой?

Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
percona-server-server-5.6
Suggested packages:
tinyca
The following NEW packages will be installed:
percona-server-server-5.6
0 upgraded, 1 newly installed, 0 to remove and 6 not upgraded.
7 not fully installed or removed.
Need to get 0 B/11.1 MB of archives.
After this operation, 94.5 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Preconfiguring packages ...
(Reading database ... 119502 files and directories currently installed.)
Preparing to unpack .../percona-server-server-5.6_5.6.23-72.1-1.trusty_amd64.deb ...
Unpacking percona-server-server-5.6 (5.6.23-72.1-1.trusty) ...
dpkg: error processing archive /var/cache/apt/archives/percona-server-server-5.6_5.6.23-72.1-1.trusty_amd64.deb (--unpack):
trying to overwrite '/usr/lib/mysql/plugin/dialog.so', which is also in package libmariadbclient18 5.5.42+maria-1~trusty
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/percona-server-server-5.6_5.6.23-72.1-1.trusty_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

---

Вылетает ошибка. Ошибка связана скорее всего из за того, что до этого был установлен MariaDB, которая не подошла из за скорости InnoDB, после чего было решено поставить Percona.
  • Вопрос задан
  • 764 просмотра
Решения вопроса 2
ushliy
@ushliy
nix-админ
sudo apt-get purge mariadb*
sudo apt-get install -f
Ответ написан
@vitalyg Автор вопроса
dpkg -r mariadb-servermariadb-client-core-5.5 mariadb-client-5.5 mariadb-server-core-5.5 libmariadbclient18
apt-get clean
apt-get install --reinstall libmysqlclient18
Ответ написан
Комментировать
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы