44Igor44
@44Igor44
-

Как установить самый новый совместимый firefox для ubuntu 8.10?

Как установить самую новую совместимую firefox для этой версии системы?
  • Вопрос задан
  • 264 просмотра
Пригласить эксперта
Ответы на вопрос 6
@Everything_is_bad
никак
Ответ написан
Комментировать
ky0
@ky0
Миллиардер, филантроп, патологический лгун
Берёте исходники самой старой версии ФФ, которую найдёте, собираете. Оно, разумеется, не запустится. Патчите все возникающие ошибки, собираете. Если сил хватает, делаете то же самое для более новой версии. Повторить.
Ответ написан
@pfg21
ex-турист
старые репы лежат здесь
https://old-releases.ubuntu.com/ubuntu/
подключи их и некрофиль дальше :)
Ответ написан
@rPman
Настоятельно не советую ковыряться со старыми версиями linux, тем более на столько старыми, там начнутся проблемы уже поиском рабочих репозитарий, поиском инструкций, настройкой сертификатов и т.п.

Самый свежий софт для старых компьютеров настоятельно рекомендую собирать из исходников с помощью gentoo. Там это автоматизировано до пары телодвижений, как бы не говорили что gentoo это сложно, если ты дошел до ситуации, когда нужно компилировать - то это лучший. Еще говорят arch хорош, но не для слабых и старых компьютеров. Я собирал себе минисборку для eepc900 с 1gb ram (DE - awesome), оно в запущенном состоянии с GUI потребляло 50мб ram (притом что пустой ubuntu требует больше 300мб и для браузера уже на остается), т.е. оставался весь гигабайт для браузера (но учти современный интернет очень ресурсоемкий, осознаешь на сколько криворукие программисты заполонили мир, банально youtube все ресурсы затрачивает на просто загрузку видео, и их не хватает на проигрывание, когда как скачанное проигрывает в 480p без проблем а с оговорками и 720p что для 15-летней давности железа очень даже хорошо)

Само собой для ускорения сборки нужно использовать быстрые машины, в gentoo для этого запилили целую инфрастуктуру с помощью distcc (пара телодвижений в конфиге) можно направить компиляцию на кластер, который запустить можно на тех же облачных vps-ках (тебе считанные часы работы обойдутся в сотню рублей). Советую сначала разобраться и попробовать на своем железе и только потом направлять на арендованное железо.

Еще совет, не заморачивайся с компиляцией ядра - это нужно тем кто тюнит сборку для совсем отбитого железа интернета вещей. Бери готовое ядро, которое идет с их livecd.
Ответ написан
Комментировать
@Kil1J0y
Последний Firefox не будет работать без следующих библиотек:
glibc 2.17 or higher
GTK+ 3.14 or higher
libglib 2.42 or higher
libstdc++ 4.8.1 or higher
X.Org 1.0 or higher (1.7 or higher is recommended)
Так же рекомендуется
DBus 1.0 or higher
NetworkManager 0.7 or higher
PulseAudio
Ответ написан
Комментировать
CityCat4
@CityCat4
Внимание! Изменился адрес почты!
Мсье некрофил? Или железо соответствующей "мощности"? Есть немного причин, по которой люди все еще используют некро-оси.

Например хрюня у нас используется в двух случаях:
- попасть на морду управления старинным интеловым кластером
- попасть на морду управления не менее старым hp
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы