@itsoftoff

На роутере Mikrotik настроить Прокси для конкретных сайтов?

Есть домашний роутер MikroTik hAP lite, Router OS v7.7. Мне нужно настроить роутер так, чтобы при запросе на определенные сайты, сервера трафик перебрасывался на прокси. Пару гайдов находил, но не особо понял что и как. Если можно как для чайника.
Переадресация нужна для обхода блокировки в моей стране.
Что бы пинг был поменьше, думаю использовать открытые прокси стран: Германии, Польши, Чехии
  • Вопрос задан
  • 466 просмотров
Решения вопроса 2
CityCat4
@CityCat4 Куратор тега Сетевое оборудование
Внимание! Изменился адрес почты!
Задача непонятна. Зачем? Обход блокировки? Подмена страниц? Прокси у микротика очень скромный по возможностям, что нифига не удивительно - это роутер, а не полноценный сервер.
Ответ написан
@dronmaxman
VoIP Administrator
Мой опыт настройки на mikrotik ac2, 7.6

# За основу была взята это статья
https://habr.com/ru/post/549282/

# Настраиваем VPN от WARP
https://habr.com/ru/post/594551/
https://github.com/ViRb3/wgcf

# Настраиваем pptp для BGP
Получаем настройки pptp у телеграм бота
https://t.me/antifilter_vpn_bot

# Настраиваем BGP
1. Делаем темплейт для BGP
/routing bgp template
set default disabled=no output.network=bgp-networks
add as=65514 disabled=no name=antifilter output.network=bgp-networks .no-client-to-client-reflection=yes router-id=10.42.1.3 routing-table=main

где
10.42.1.3 - pptp адрес mikrotik

2. Настраиваем фильтр для входящих маршрутов, который переписывает GW
/routing filter rule
add chain=discard disabled=no rule="reject;"
add chain=antifilter-in disabled=no rule="set gw *0x4a; accept;"

где
*0x4a - имя интерфейса для обхода блокировки, в моем случае wireguard WARP, лучше настраивать через winbox GUI

3. Поднимаем BGP
/routing bgp connection
add as=65514 connect=yes disabled=no hold-time=4m input.filter=antifilter-in keepalive-time=1s listen=yes local.address=10.42.1.3 .role=ebgp multihop=yes name=rublacklist output.filter-chain=discard .network=bgp-networks \
    .no-client-to-client-reflection=yes remote.address=10.75.66.20/32 .as=65444 .port=643 router-id=91.231.206.202 routing-table=main templates=antifilter

где
65514 - АS с твоей стороны, выбираем любой от 65000-65999
65444 - АS отдающая маршруты, выбрать можно тут https://antifilter.network/bgp, я выбрал весь RU сегмент

4. VPN от CF warp имеет свойство падать если в нем не ходит трафик, добавил костыль в виде ping yDNS
/tool netwatch
add disabled=no down-script="" host=77.88.8.8 http-codes="" interval=30s test-script="" type=icmp up-script=""
Ответ написан
Пригласить эксперта
Ответы на вопрос 1
@Drno
Я бы советовал проект Антизапрет. И лучше на своём ВПС.
Далее на микроте в адрес лист надо напихать нужные домены с пометкой.
В мангл сделать маркировку
И задать правильный роут
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы