@romicohen
Системный Архитектор

Обновил PHP до 8.2 на Ubuntu — сломались репозитории (couldn't be verified because the public key is not available) — что делать?

Hit:5 http://ppa.launchpad.net/ondrej/php/ubuntu focal InRelease
Get:6 https://ppa.launchpadcontent.net/ondrej/php/ubuntu focal InRelease [23.9 kB]
Err:6 https://ppa.launchpadcontent.net/ondrej/php/ubuntu focal InRelease
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 4F4EA0AAE5267A6C
Reading package lists... Done
W: GPG error: https://ppa.launchpadcontent.net/ondrej/php/ubuntu focal InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 4F4EA0AAE5267A6C
E: The repository 'https://ppa.launchpadcontent.net/ondrej/php/ubuntu focal InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.


63cfcd7711c98514470417.png

На самом деле у меня постоянно такая ерунда с репозиториями :-(

Я вроде и гуглю чего-то - но рецепты не помогают.

Как это можно решить в принципе?

И зачем столько сложностей? (это риторический вопрос от усталости))))
  • Вопрос задан
  • 174 просмотра
Пригласить эксперта
Ответы на вопрос 1
Rsa97
@Rsa97
Для правильного вопроса надо знать половину ответа
sudo mkdir /root/.gnupg
sudo chmod 600 /root/.gnupg
sudo gpg --no-default-keyring --keyring gnupg-ring:/etc/apt/trusted.gpg.d/ondrej.gpg --keyserver hkps://keyserver.ubuntu.com --recv 4F4EA0AAE5267A6C
sudo chmod 644 /etc/apt/trusted.gpg.d/ondrej.gpg
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы