@Kerm

Не получается подружить symfony 3.4 с NelmioApiDocBundle в чем проблема?

Вот есть инструкция: https://symfony.com/bundles/NelmioApiDocBundle/cur...

По ней у меня ни чего не получилось сделать, у меня из всех файлов, в которые нужно вносить изменения, нет ни одного, единственное что у меня есть, это app/config/routing.yml, где я указал:

app:
  resource: '@AppBundle/Controller/'
  type: annotation
NelmioApiDocBundle:
  resource: "@NelmioApiDocBundle/Resources/config/routing/swaggerui.xml"
  prefix: /api/doc/


Страница с описанием моих апи у меня открылась, но там много лишнего, прям очень много, туда попали _profiller и т.д

В описании по ссылке выше указано:

Нужно в файл config/packages/nelmio_api_doc.yaml добавить areas, но дело в том у меня в проекте даже папки такой packages ни когда такой не было и даже если вручную создать папку эту и файл то ни чего не работает! И config/routes.yaml у меня нет такого файла, подозреваю что они свою инструкцию писали для более новых версий symfony...

Подскажите пожалуйста как для моей версии symfony добавить эти исключения для роутов, чтобы не все что попало попадало туда, как мне указать чтобы только /api ссылки попадали в описание?
  • Вопрос задан
  • 32 просмотра
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы