@Shelushun

Установка wiki.js. Вызывает ошибку при установке пакета npm i fs-extra. Как быть?

Wiki.js требует при инсталляции пакет fs-extra, хотя при установке на windows он этот пакет не требует и там запускается все с полупинка.

При попытке установить
npm i fs-extra
ошибка
npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR!
npm ERR! While resolving: wiki@2.5.289
npm ERR! Found: graphql@15.3.0
npm ERR! node_modules/graphql
npm ERR!   graphql@"15.3.0" from the root project
npm ERR!
npm ERR! Could not resolve dependency:
npm ERR! peer graphql@"^0.11.0 || ^0.12.0 || ^0.13.0 || ^14.0.0" from apollo-link-persisted-queries@0.2.2
npm ERR! node_modules/apollo-link-persisted-queries
npm ERR!   dev apollo-link-persisted-queries@"0.2.2" from the root project
npm ERR!
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.
npm ERR!
npm ERR! See /root/.npm/eresolve-report.txt for a full report.

npm ERR! A complete log of this run can be found in:
npm ERR!     /root/.npm/_logs/2022-09-29T08_39_21_583Z-debug-0.log


При попытке так
npm i fs-extra --legacy-peer-deps
Ошибка следующая

npm WARN deprecated stable@0.1.8: Modern JS already guarantees Array#sort() is a stable s                      ort, so this library is deprecated. See the compatibility table on MDN: https://developer                      .mozilla.org/en-US/docs/Web/JavaScript/Reference/Global_Objects/Array/sort#browser_compat                      ibility
npm WARN deprecated flatten@1.0.3: flatten is deprecated in favor of utility frameworks s                      uch as lodash.
npm WARN deprecated @braintree/sanitize-url@3.1.0: Potential XSS vulnerability patched in                       v6.0.0.
npm WARN deprecated browserslist@2.11.3: Browserslist 2 could fail on reading Browserslis                      t >3.0 config used in other tools.
npm WARN deprecated browserslist@2.11.3: Browserslist 2 could fail on reading Browserslis                      t >3.0 config used in other tools.
npm WARN deprecated browserslist@2.11.3: Browserslist 2 could fail on reading Browserslis                      t >3.0 config used in other tools.
npm WARN deprecated shvl@2.0.3: older versions vulnerable to prototype pollution
npm WARN deprecated chokidar@2.1.8: Chokidar 2 does not receive security updates since 20                      19. Upgrade to chokidar 3 with 15x fewer dependencies
npm WARN deprecated babel-eslint@10.1.0: babel-eslint is now @babel/eslint-parser. This p                      ackage will no longer receive updates.
npm WARN deprecated sane@4.1.0: some dependency vulnerabilities fixed, support for node <                       10 dropped, and newer ECMAScript syntax/features added
npm WARN deprecated uuid@3.4.0: Please upgrade  to version 7 or higher.  Older versions m                      ay use Math.random() in certain circumstances, which is known to be problematic.  See htt                      ps://v8.dev/blog/math-random for details.
npm WARN deprecated vuex-persistedstate@3.1.0: Package no longer supported. Contact Suppo                      rt at https://www.npmjs.com/support for more info.
npm WARN deprecated i18next-xhr-backend@3.2.2: replaced by i18next-http-backend
npm WARN deprecated @babel/polyfill@7.12.1: 🚨 This package has been deprecated in favo                      r of separate inclusion of a polyfill and regenerator-runtime (when needed). See the @bab                      el/polyfill docs (https://babeljs.io/docs/en/babel-polyfill) for more information.
npm WARN deprecated postcss-cssnext@3.1.1: 'postcss-cssnext' has been deprecated in favor                       of 'postcss-preset-env'. Read more at https://moox.io/blog/deprecating-cssnext/
npm WARN deprecated svgo@1.3.2: This SVGO version is no longer supported. Upgrade to v2.x                      .x.
npm WARN deprecated viz.js@2.1.2: no longer supported
npm WARN deprecated core-js@2.6.12: core-js@<3.23.3 is no longer maintained and not recom                      mended for usage due to the number of issues. Because of the V8 engine whims, feature det                      ection in old core-js versions could cause a slowdown up to 100x even if nothing is polyf                      illed. Some versions have web compatibility issues. Please, upgrade your dependencies to                       the actual version of core-js.
npm WARN deprecated core-js@2.6.12: core-js@<3.23.3 is no longer maintained and not recom                      mended for usage due to the number of issues. Because of the V8 engine whims, feature det                      ection in old core-js versions could cause a slowdown up to 100x even if nothing is polyf                      illed. Some versions have web compatibility issues. Please, upgrade your dependencies to                       the actual version of core-js.
npm WARN deprecated core-js@3.6.5: core-js@<3.23.3 is no longer maintained and not recomm                      ended for usage due to the number of issues. Because of the V8 engine whims, feature dete                      ction in old core-js versions could cause a slowdown up to 100x even if nothing is polyfi                      lled. Some versions have web compatibility issues. Please, upgrade your dependencies to t                      he actual version of core-js.
npm ERR! code 1
npm ERR! path /var/www/wiki/node_modules/cypress
npm ERR! command failed
npm ERR! command sh -c -- node index.js --exec install
npm ERR! /var/www/wiki/node_modules/fs-extra/lib/mkdirs/make-dir.js:85
npm ERR!       } catch {
npm ERR!               ^
npm ERR!
npm ERR! SyntaxError: Unexpected token {
npm ERR!     at createScript (vm.js:80:10)
npm ERR!     at Object.runInThisContext (vm.js:139:10)
npm ERR!     at Module._compile (module.js:616:28)
npm ERR!     at Object.Module._extensions..js (module.js:663:10)
npm ERR!     at Module.load (module.js:565:32)
npm ERR!     at tryModuleLoad (module.js:505:12)
npm ERR!     at Function.Module._load (module.js:497:3)
npm ERR!     at Module.require (module.js:596:17)
npm ERR!     at require (internal/module.js:11:18)
npm ERR!     at Object.<anonymous> (/var/www/wiki/node_modules/fs-extra/lib/mkdirs/index.                      js:3:44)
npm ERR!     at Module._compile (module.js:652:30)
npm ERR!     at Object.Module._extensions..js (module.js:663:10)
npm ERR!     at Module.load (module.js:565:32)
npm ERR!     at tryModuleLoad (module.js:505:12)
npm ERR!     at Function.Module._load (module.js:497:3)
npm ERR!     at Module.require (module.js:596:17)

npm ERR! A complete log of this run can be found in:
npm ERR!     /root/.npm/_logs/2022-09-29T08_21_57_388Z-debug-0.log


Версия node 16.7.1
В логах очень слаб как и в самой системе ubuntu. Подскажите пожалуйста кто знает.
  • Вопрос задан
  • 137 просмотров
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы