Slash-Zn
@Slash-Zn

Почему при переключении на PHP 8.1 Яндекс и Google натыкаются на 500 ошибку?

Здравствуйте.
Яндекс и Google в один голос твердят, что страницы недоступны, мол ошибка 500. Делаю проверку доступности сайта в Яндексе, Яндекс говорит ошибка 500, а я в это время на проверяемой странице и все работает... Тоже самое и с Google...

Движок работает на PHP 8.1.6 и при этой версии Яндекс и Google выдает 500 ошибку.
Меняю версию PHP на 8.0.19 и Яндекс с Google сразу видят сайт...
А при чем тут версия интерпретатора? Я не знаю...

Как можно "жить" на последней версии PHP и быть доступным для поисковиков?

Спасибо.

- Ubuntu 18.04 LTS
- ISPmanager 6 Lite
- RAM 2048
- DISK 20 ГБ
- CPU 2
  • Вопрос задан
  • 168 просмотров
Пригласить эксперта
Ответы на вопрос 1
Rsa97
@Rsa97
Для правильного вопроса надо знать половину ответа
Ошибка 500 возвращается с сайта. Смотрите логи на своём сервере.
А при чем тут версия интерпретатора?
Что-то из статуса deprecated перешло в removed. Какие-то ошибки вместо warning начали выдавать error.
https://www.php.net/manual/en/migration81.incompat...
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы