Ivseti
@Ivseti

Как в функции ВПР сравнить и заменить более одного элемента в ячейке?

Ипользуюю функцию ВПР. Но возник вопрос, если нужно сравнить и подставить большое одного значения в ячейке ?
=ВПР(C5;$A:$B;2;ЛОЖЬ)
Мой пример:
6275583822b27658697985.jpeg
  • Вопрос задан
  • 49 просмотров
Пригласить эксперта
Ответы на вопрос 1
@Alesso
Вариант 1. Разгруппировать 23,24,27 на отдельные строки и использовать ВПР.

Вариант 2. Пример с ячейкой 23,24,27. В ячейке справа генерируете формулу = "ВПР("&ПОДСТАВИТЬ(С5, ",";";A2:B1000;2;0)&","&ВПР(")&";A2:B1000;2;0)"
Пишу с телефона. Поэтому надо проверить и отладить эту функцию.
Суть: запятые меняем на отдельные части формулы ВПР, ВПР добавляем в начало и в конец.
Далее оживляете формулу через evaluate функцию: https://exceloffthegrid.com/turn-string-formula-wi...
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы