@ALEXLEMUR
Инженер

Как резервировать DMVPN ?

Здравствуйте есть задача резервировать DNVPN по средством второго ISP . Центральный офис находиться в городе Ставрополь а два филиалы в Москве и в Питере. Центральный маршрутизатор Ставрополя является Hub а филиалы Spoke.
d15995593c33dc75035244ac89cf85e5.jpg

Сейчас настроено все через одного ISP (ISP1) но начальник решил сделать резервирование и подключили второй канал (ISP2).
Как я понял надо поднять по одному туннелю в филиалах и еще один Hub на центральном.
Вопрос в том как связать это все с IP SLA и OSPF? И как правильно сконфигурить Хаба?
Конфига ХАба!
Building configuration...

Current configuration : 1731 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Stav
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
clock timezone CET 1 0
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip auth-proxy max-login-attempts 5
ip admission max-login-attempts 5
!
!
!
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
crypto pki token default removal timeout 0
!
!
!
redundancy
!
!
!
!
!
!
!
crypto isakmp policy 1
authentication pre-share
crypto isakmp key DMVPNpass address 0.0.0.0
!
!
crypto ipsec transform-set AES128-SHA esp-aes esp-sha-hmac
mode transport
!
crypto ipsec profile DMVPN-P
set transform-set AES128-SHA
!
!
!
!
!
!
!
interface Tunnel0
ip address 192.168.1.1 255.255.255.0
no ip redirects
ip nhrp map multicast dynamic
ip nhrp network-id 1
ip ospf network broadcast
ip ospf priority 100
tunnel source Ethernet0/0
tunnel mode gre multipoint
tunnel protection ipsec profile DMVPN-P
!
interface Ethernet0/0
ip address 30.30.30.2 255.255.255.0
!
interface Ethernet0/1
ip address 40.40.40.2 255.255.255.0
!
interface Ethernet0/2
ip address 172.16.32.1 255.255.252.0
!
interface Ethernet0/3
no ip address
shutdown
!
router ospf 1
network 172.16.32.0 0.0.3.255 area 0
network 192.168.1.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 30.30.30.1 10
ip route 0.0.0.0 0.0.0.0 40.40.40.1 50
!
!
!
!
control-plane
!
!
!
!
!
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
exec-timeout 0 0
login
transport input all
!
!
end
  • Вопрос задан
  • 3432 просмотра
Решения вопроса 1
Arxdenis
@Arxdenis
Добрый день,
Обратите внимание на документацию, очень подробно расписано с примерами.
В переводе: Динамические многоточечные виртуальные частные сет...
Оригинал: Dynamic Multipoint IPsec VPNs (Using Multipoint GR...
Ответ написан
Пригласить эксперта
Ответы на вопрос 1
@ALEXLEMUR Автор вопроса
Инженер
Спасибо изучаю! А есть ли еще сылочка да документацию по IP SLA ?
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы