@1RatavA1
Начинающий full-stack

Mozilla firefox, как решить проблему в manifest.json?

При добавлении временного расширения в mozilla firefox проблему: Extension is invalid. Reading manifest: Property "description" is unsupported in Manifest Version 1.

Сам manifest.json:
{
  "name": "Запускаем снежинки на любом сайте",
  "description": "Проект журнала Код",
  "version": "1.0",
  "manifest_version": 1,

  "permissions": ["activeTab", "scripting"],

  "action": {
    "default_popup": "popup.html",
    "default_icon": {
      "16": "/images/get_started16.png",
      "32": "/images/get_started32.png",
      "48": "/images/get_started48.png",
      "128": "/images/get_started128.png"
    }
  },

  "icons": {
    "16": "/images/get_started16.png",
    "32": "/images/get_started32.png",
    "48": "/images/get_started48.png",
    "128": "/images/get_started128.png"
  }
}
  • Вопрос задан
  • 44 просмотра
Пригласить эксперта
Ответы на вопрос 1
@GrayHorse
Property "description" is unsupported in Manifest Version 1

"manifest_version": 1,

Ну так используй 2-ю версию манифеста.
Вторая — не третья.

1-я версия не актуальна уже лет десять.
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы