@DarkyKira

Почему Atom и Sublime text не хотят устанавливать плагины?

Пытался установить русский язык в эти редакторы текста,но что в Atom что в ST ничего не устанавливается,потом я выяснил что другие плагины тоже не хотят устанавливаться.
Вот лог от атома:
spoiler
0 info it worked if it ends with ok
1 verbose cli [
1 verbose cli 'C:\\Users\\kirit\\AppData\\Local\\atom\\app-1.58.0\\resources\\app\\apm\\bin\\node.exe',
1 verbose cli 'C:\\Users\\kirit\\AppData\\Local\\atom\\app-1.58.0\\resources\\app\\apm\\node_modules\\npm\\bin\\npm-cli.js',
1 verbose cli '--globalconfig',
1 verbose cli 'C:\\Users\\kirit\\.atom\\.apm\\.apmrc',
1 verbose cli '--userconfig',
1 verbose cli 'C:\\Users\\kirit\\.atom\\.apmrc',
1 verbose cli 'install',
1 verbose cli 'https://www.atom.io/api/packages/atom-i18n/version...',
1 verbose cli '--target=9.4.4',
1 verbose cli '--disturl=https://atom.io/download/electron',
1 verbose cli '--arch=x64',
1 verbose cli '--global-style'
1 verbose cli ]
2 info using npm@6.14.13
3 info using node@v12.14.1
4 verbose npm-session bb86a2e39d3cbe5a
5 silly install loadCurrentTree
6 silly install readLocalPackageData
7 silly fetchPackageMetaData error for https://www.atom.io/api/packages/atom-i18n/version... request to https://codeload.github.com/liuderchi/atom-i18n/le... failed, reason: connect ECONNREFUSED 127.0.0.1:443
8 timing stage:rollbackFailedOptional Completed in 0ms
9 timing stage:runTopLevelLifecycles Completed in 300771ms
10 verbose type system
11 verbose stack FetchError: request to https://codeload.github.com/liuderchi/atom-i18n/le... failed, reason: connect ECONNREFUSED 127.0.0.1:443
11 verbose stack at ClientRequest. (C:\Users\kirit\AppData\Local\atom\app-1.58.0\resources\app\apm\node_modules\npm\node_modules\node-fetch-npm\src\index.js:68:14)
11 verbose stack at ClientRequest.emit (events.js:223:5)
11 verbose stack at TLSSocket.socketErrorListener (_http_client.js:406:9)
11 verbose stack at TLSSocket.emit (events.js:223:5)
11 verbose stack at emitErrorNT (internal/streams/destroy.js:92:8)
11 verbose stack at emitErrorAndCloseNT (internal/streams/destroy.js:60:3)
11 verbose stack at processTicksAndRejections (internal/process/task_queues.js:81:21)
12 verbose cwd C:\Users\kirit\AppData\Local\Temp\apm-install-dir-2021104-7608-3sv7aj.x5g0i
13 verbose Windows_NT 10.0.19042
14 verbose argv "C:\\Users\\kirit\\AppData\\Local\\atom\\app-1.58.0\\resources\\app\\apm\\bin\\node.exe" "C:\\Users\\kirit\\AppData\\Local\\atom\\app-1.58.0\\resources\\app\\apm\\node_modules\\npm\\bin\\npm-cli.js" "--globalconfig" "C:\\Users\\kirit\\.atom\\.apm\\.apmrc" "--userconfig" "C:\\Users\\kirit\\.atom\\.apmrc" "install" "https://www.atom.io/api/packages/atom-i18n/version..." "--target=9.4.4" "--disturl=https://atom.io/download/electron" "--arch=x64" "--global-style"
15 verbose node v12.14.1
16 verbose npm v6.14.13
17 error code ECONNREFUSED
18 error errno ECONNREFUSED
19 error FetchError: request to https://codeload.github.com/liuderchi/atom-i18n/le... failed, reason: connect ECONNREFUSED 127.0.0.1:443
19 error at ClientRequest. (C:\Users\kirit\AppData\Local\atom\app-1.58.0\resources\app\apm\node_modules\npm\node_modules\node-fetch-npm\src\index.js:68:14)
19 error at ClientRequest.emit (events.js:223:5)
19 error at TLSSocket.socketErrorListener (_http_client.js:406:9)
19 error at TLSSocket.emit (events.js:223:5)
19 error at emitErrorNT (internal/streams/destroy.js:92:8)
19 error at emitErrorAndCloseNT (internal/streams/destroy.js:60:3)
19 error at processTicksAndRejections (internal/process/task_queues.js:81:21)
19 error FetchError: request to https://codeload.github.com/liuderchi/atom-i18n/le... failed, reason: connect ECONNREFUSED 127.0.0.1:443
19 error at ClientRequest. (C:\Users\kirit\AppData\Local\atom\app-1.58.0\resources\app\apm\node_modules\npm\node_modules\node-fetch-npm\src\index.js:68:14)
19 error at ClientRequest.emit (events.js:223:5)
19 error at TLSSocket.socketErrorListener (_http_client.js:406:9)
19 error at TLSSocket.emit (events.js:223:5)
19 error at emitErrorNT (internal/streams/destroy.js:92:8)
19 error at emitErrorAndCloseNT (internal/streams/destroy.js:60:3)
19 error at processTicksAndRejections (internal/process/task_queues.js:81:21) {
19 error message: 'request to https://codeload.github.com/liuderchi/atom-i18n/le... failed, reason: connect ECONNREFUSED 127.0.0.1:443',
19 error type: 'system',
19 error errno: 'ECONNREFUSED',
19 error code: 'ECONNREFUSED',
19 error stack: 'FetchError: request to https://codeload.github.com/liuderchi/atom-i18n/le... failed, reason: connect ECONNREFUSED 127.0.0.1:443\n' +
19 error ' at ClientRequest. (C:\\Users\\kirit\\AppData\\Local\\atom\\app-1.58.0\\resources\\app\\apm\\node_modules\\npm\\node_modules\\node-fetch-npm\\src\\index.js:68:14)\n' +
19 error ' at ClientRequest.emit (events.js:223:5)\n' +
19 error ' at TLSSocket.socketErrorListener (_http_client.js:406:9)\n' +
19 error ' at TLSSocket.emit (events.js:223:5)\n' +
19 error ' at emitErrorNT (internal/streams/destroy.js:92:8)\n' +
19 error ' at emitErrorAndCloseNT (internal/streams/destroy.js:60:3)\n' +
19 error ' at processTicksAndRejections (internal/process/task_queues.js:81:21)'
19 error }
20 error If you are behind a proxy, please make sure that the
20 error 'proxy' config is set properly. See: 'npm help config'
21 verbose exit [ 1, true ]


А тут информация с консоли Sublime text:

spoiler
DPI mode: per-monitor v2
startup, version: 4121 windows x64 channel: stable
executable: /C/Program Files/Sublime Text/sublime_text.exe
application: /C/Program Files/Sublime Text
working dir: /C/Program Files/Sublime Text
packages path: /C/Users/kirit/AppData/Roaming/Sublime Text/Packages
state path: /C/Users/kirit/AppData/Roaming/Sublime Text/Local
zip path: /C/Program Files/Sublime Text/Packages
zip path: /C/Users/kirit/AppData/Roaming/Sublime Text/Installed Packages
ignored_packages: ["Vintage"]
pre session restore time: 0.225172
startup time: 0.326172
first paint time: 0.328172
reloading plugin Default.arithmetic
reloading plugin Default.auto_indent_tag
reloading plugin Default.block
reloading plugin Default.colors
reloading plugin Default.comment
reloading plugin Default.convert_color_scheme
reloading plugin Default.convert_syntax
reloading plugin Default.copy_path
reloading plugin Default.echo
reloading plugin Default.exec
reloading plugin Default.fold
reloading plugin Default.font
reloading plugin Default.goto_line
reloading plugin Default.history_list
reloading plugin Default.html_print
reloading plugin Default.indentation
reloading plugin Default.install_package_control
reloading python 3.3 plugin 0_package_control_loader.00-package_control
reloading python 3.3 plugin Package Control.1_reloader
reloading python 3.3 plugin Package Control.2_bootstrap
reloading plugin Default.keymap
reloading plugin Default.kill_ring
reloading plugin Default.mark
reloading plugin Default.new_templates
reloading plugin Default.open_context_url
reloading plugin Default.open_in_browser
reloading plugin Default.pane
reloading plugin Default.paragraph
reloading plugin Default.paste_from_history
reloading plugin Default.profile
reloading plugin Default.quick_panel
reloading plugin Default.rename
reloading plugin Default.run_syntax_tests
reloading plugin Default.save_on_focus_lost
reloading plugin Default.scroll
reloading plugin Default.set_unsaved_view_name
reloading plugin Default.settings
reloading plugin Default.show_scope_name
reloading plugin Default.side_bar
reloading plugin Default.sort
reloading plugin Default.switch_file
reloading plugin Default.symbol
reloading plugin Default.transform
reloading plugin Default.transpose
reloading plugin Default.ui
reloading plugin CSS.css_completions
reloading plugin Diff.diff
reloading plugin HTML.encode_html_entities
reloading plugin HTML.html_completions
reloading plugin ShellScript.ShellScript
reloading python 3.3 plugin Package Control.Package Control
plugins loaded
Package Control: Skipping automatic upgrade, last run at 2021-11-04 14:06:19, next run at 2021-11-04 15:06:19 or after
ignored packages updated to: ["LocalizedMenu", "Vintage"]
reloading settings Packages/User/Package Control.sublime-settings
reloading settings Packages/User/Preferences.sublime-settings
Package Control: Attempting to use Urllib downloader due to WinINet error: Error downloading package. Connection refused (errno 12029) during HTTP write phase of downloading https://codeload.github.com/zam1024t/LocalizedMenu....
Package Control: Error downloading package. URL error [WinError 10061] Подключение не установлено, т.к. конечный компьютер отверг запрос на подключение downloading https://codeload.github.com/zam1024t/LocalizedMenu....
error: Package Control

Unable to download LocalizedMenu. Please view the console for more details.
ignored packages updated to: ["Vintage"]
reloading settings Packages/User/Package Control.sublime-settings
reloading settings Packages/User/Preferences.sublime-settings

Пробовал отключать антивирус (у меня только защитник винды)
Брэндмауэр (в нём также разрешение для этих программ сделал)
и удалил adguard
сами программы я также переустанавливал
Когда пытался найти информацию в интернете,то особо ничего не нашёл
у кого-то антивирус блочил
а кто-то писал что-то про host
но проблему в любом случае не удалось решить
  • Вопрос задан
  • 98 просмотров
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы