@ymenaidtopa

Делаю create-vk-mini-app, выдает ошибку?

Сама ошибка:
C:\Users\User_ml\Desktop\чай>create-vk-mini-app app
 Creating project...
⏱ Installing project dependencies — it might take a few minutes..
 npm error:
Error: Command failed: cd app && npm install cross-env@^7.0.3 react-hot-loader@^4.13.0 react-scripts@^4.0.3 --save-dev && npm install @vkontakte/icons@^1.92.0 @vkontakte/vk-miniapps-deploy@0.0.25 @vkontakte/vkui@^4.5.0 babel-eslint@^10.1.0 chalk@^4.1.0 eruda@^2.4.1 eruda-code@^2.0.0 eruda-dom@^2.0.0  prop-types@^15.7.2 react@^17.0.2 react-dom@^17.0.2 @vkontakte/vk-bridge@latest @vkontakte/vkjs@latest
npm WARN deprecated flatten@1.0.3: flatten is deprecated in favor of utility frameworks such as lodash.
npm WARN deprecated @hapi/bourne@1.3.2: This version has been deprecated and is no longer supported or maintained
npm WARN deprecated @hapi/topo@3.1.6: This version has been deprecated and is no longer supported or maintained
npm WARN deprecated urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
npm WARN deprecated chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.
npm WARN deprecated chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.
npm WARN deprecated resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated
npm WARN deprecated querystring@0.2.1: The querystring API is considered Legacy. new code should use the URLSearchParams API instead.
npm WARN deprecated sane@4.1.0: some dependency vulnerabilities fixed, support for node < 10 dropped, and newer ECMAScript syntax/features added
npm WARN deprecated @hapi/address@2.1.4: Moved to 'npm install @sideway/address'
npm WARN deprecated rollup-plugin-babel@4.4.0: This package has been deprecated and is no longer maintained. Please use @rollup/plugin-babel.
npm WARN deprecated querystring@0.2.0: The querystring API is considered Legacy. new code should use the URLSearchParams API instead.
npm WARN deprecated babel-eslint@10.1.0: babel-eslint is now @babel/eslint-parser. This package will no longer receive updates.
npm WARN deprecated uuid@3.4.0: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.
npm WARN deprecated uuid@3.4.0: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.
npm WARN deprecated @hapi/hoek@8.5.1: This version has been deprecated and is no longer supported or maintained
npm WARN deprecated @hapi/joi@15.1.1: Switch to 'npm install joi'
npm WARN deprecated core-js@2.6.12: core-js@<3.3 is no longer maintained and not recommended for usage due to the number of issues. Because of the V8 engine whims, feature detection in old core-js versions could cause a slowdown up to 100x even if nothing is polyfilled. Please, upgrade your dependencies to the actual version of core-js.
npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR!
npm ERR! While resolving: app@1.0.0
npm ERR! Found: @vkontakte/vkjs@0.22.1
npm ERR! node_modules/@vkontakte/vkjs
npm ERR!   @vkontakte/vkjs@"0.22.1" from the root project
npm ERR!
npm ERR! Could not resolve dependency:
npm ERR! peer @vkontakte/vkjs@"^0.20.0" from @vkontakte/vkui@4.5.0
npm ERR! node_modules/@vkontakte/vkui
npm ERR!   @vkontakte/vkui@"4.5.0" from the root project
npm ERR!
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.
npm ERR!
npm ERR! See C:\Users\User_ml\AppData\Local\npm-cache\eresolve-report.txt for a full report.

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\User_ml\AppData\Local\npm-cache\_logs\2021-09-28T16_55_26_944Z-debug.log
  • Вопрос задан
  • 131 просмотр
Пригласить эксперта
Ответы на вопрос 1
@romant094
Frontend-developer
Какая версия ноды у вас?
Возможно, это решит вопрос: Fix the upstream dependency conflict, or retry this command with --force, or --legacy-peer-deps
У вас в логе написано это.
Еще нашел статью об этом: https://go.innoscripta.com/615eba813f727
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы