@YeaNot

Как в Excel найти кол-во ячеек, которые содержат определённое значение?

Есть столбец, где в каждой ячейке находится несколько слов через запятую. Как я могу получить кол-во ячеек, которые содержат определённое слово?

Например:
A1: Дыня, арбуз, ананас
A2: Огурец, помидор, арбуз
A3: Вишня, огурец, ананас

В 2-х из них есть слово "арбуз". Но нужно это получить через формулу.
  • Вопрос задан
  • 51 просмотр
Решения вопроса 1
Krasnoarmeec
@Krasnoarmeec
{=СУММ(ЕСЛИ(ЕЧИСЛО(ПОИСК(E6;$A$1:$A$3));1;0))}
или
{=SUM(IF(ISNUMBER(SEARCH(E6;$A$1:$A$3));1;0))}

где $A$1:$A$3 - Ваш массив строк,
E6 - содержит искомый "арбуз",
{} означает операцию с массивом (Ctrl+Shift+Enter при вводе формулы).
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы