• Совместим bitrix (v20.0.1198) и php7.4?

    gromdron
    @gromdron
    Работаю с Bitrix24
    TLDR: Пока рано.

    Update: Прошу прощения. Напутал с версии: с 01.08.2020 будет требовать php 7.2, но рекомендуется php7.4


    Имея опыт в системном администрировании (как минимум подкрутить настройки php), программирования (php) и знания работы битрикса, вы можете запустить его на php 7.4 и он даже будет работать (по большей части). Он заведется, но корректно работать на все 100% не будет.

    Официально обьявлено, что с 1 июля (или июня) 2020 года платформа будет требовать php 7.2. Предполагаю что за несколько дней до релиза выйдет обновление, которое заменит str*-функции на mb_* функции и вы сможете использовать последнюю версию платформы на php 7.4.

    Если Вы используете bitrix env, то повышение версии php выйдет несколько позже (как всегда опоздают).
    Ответ написан
    3 комментария