@CenterJoin

Не удается обновить плагин в composer.json?

Когда запускаю юнит тесты через терминал выдает ошибку:
Installing dependencies from lock file (including require-dev)
Verifying lock file contents can be installed on current platform.
Your lock file does not contain a compatible set of packages. Please run composer update.

  Problem 1
    - symfony/flex is locked to version v1.4.6 and an update of this package was not requested.
    - symfony/flex v1.4.6 requires composer-plugin-api ^1.0 -> found composer-plugin-api[2.0.0] but it does not match the constraint.

You are using Composer 2, which some of your plugins seem to be incompatible with. Make sure you update your plugins or report a plugin-issue to ask them to support Composer 2.
ERROR: Job failed: exit code 1
FATAL: exit code 1


Устанавливал новую версию плагина через терминал;
Указывал версию плагина вручную, потом обновлял composer.json и composer.lock
но по-прежнему вижу эту ошибку. Как решить проблему?
  • Вопрос задан
  • 116 просмотров
Решения вопроса 2
@Flying
Там ведь прямо написано: у вас установлен Composer 2, а в composer.lock находится symfony/flex версии 1.4.6, работающий только с Composer 1.x.

Либо откатывайте Composer на 1.x (чего лучше не делать без веских причин) либо обновляйте symfony/flex на совместимую версию, 1.8 или выше.

Судя по всему этот процесс у вас идёт где-то в CI pipeline или чём-то похожем. Поэтому локальная уствновка пакета не поможет, важно чтобы нужная версия была в composer.lock.
Ответ написан
@CenterJoin Автор вопроса
t.к. я использовал gitlab-runner, к-рый берет composer.lock из моего проекта в gitlab, то нужно было обновить composer.lock на сервере, я же пытался локально (по крайней мере не пушился). Обновил на сервере и - дело пошло!
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы