goszowski
@goszowski
PHP Developer

Composer install после обновления не устанавливает зависимости. Как его починить?

Склонировал репозиторий в homestead. Пытаюсь установить зависимости composer install.
Все скачивает, обновляет, но в конце не может что-то запустить, а потом и удалить:

- Installing composer/package-versions-deprecated (1.11.99.1): Extracting archive
Plugin initialization failed (include(/home/vagrant/dms2/vendor/composer/package-versions-deprecated/src/PackageVersions/Installer.php): failed to open stream: No such file or directory), uninstalling plugin
  - Removing composer/package-versions-deprecated (1.11.99.1)
    Install of composer/package-versions-deprecated failed
                                                                                        
  [RuntimeException]                                                                    
  Could not delete /home/vagrant/dms2/vendor/composer/package-versions-deprecated/src:


В результате зависимости не установлены, проект не собран.
Как починить?
  • Вопрос задан
  • 107 просмотров
Пригласить эксперта
Ответы на вопрос 1
goszowski
@goszowski Автор вопроса
PHP Developer
Помогло запустить с опцией composer install --no-plugins
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы