@Nivaech

Как в Excel сравнить две ячейки и выдать не повторяющиеся значения?

Нужно сравнить в экселе две ячейки, и в результате выполнения функции вернуть значения цифр, которые в этих ячейках не совпадают.

Например:
Ячейка А: 2, 5, 7, 9, 3
Ячейка Б: 3, 4, 7, 2, 9

Числа, которые есть в обеих ячейках должны игнорироваться - это 2, 7, 3, 9
А те, что не повторяются, и должны выдаваться в результате, то есть это 4 и 5.
Как можно подобное провернуть?
  • Вопрос задан
  • 56 просмотров
Пригласить эксперта
Ответы на вопрос 4
StupidQuestion
@StupidQuestion
Задаю глупые вопросы...
А если....

Выделяем 2 столбца
Главная -> Условное форматирование -> Правила выделения ячеек -> Повторяющиеся значения...
Ответ написан
ForestAndGarden
@ForestAndGarden
Тостер вам не Яндекс! Задавайте вопросы грамотно.
planetaexcel.ru/techniques/7/5636/
Ответ написан
@ClearAirTurbulence
нифига непонятно.
"ячейки А" в экселе нет. В нем может быть ячейка А1, А2, и т.п.
Так что либо вы ведете речь о столбцах-строках, либо у вас в ячейке А1 хранятся данные в виде строки со значением "2, 5, 7, 9, 3" и т.п.

Проще вставить скрин.

Если речь идет о столбцах, то можно использовать условное форматирование.
см. секцию "Example: Compare Two Columns and Highlight Mismatched Data" в статье
https://trumpexcel.com/compare-two-columns/
5fb7bb5e4f44e126079480.jpeg
Ответ написан
ProgrammerForever
@ProgrammerForever
Учитель, автоэлектрик, программист, музыкант
C1: =ЕСЛИ(A1=B1;A1;"")
D1: =ЕСЛИ(A1=B1;B1;"")
... и распространить вниз

В гугл таблицах ещё проще:
=FILTER(a:b;a:a<>b:b)
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы