Hiroshima
@Hiroshima
Ровный пацанчик нигде не пропадет !

Как обновить mkdirp, чтобы установить express?

Главная проблема заключается в том что я не могу создать скелет express (или же установить express).
При попытки установить express выдает ошибку: "npm WARN deprecated mkdirp@0.5.1: Legacy versions of mkdirp are no longer supported. Please update to mkdirp 1.x. (Note that the API surface has changed to use Promises in 1.x.)". Дословно тут говорится о том что, mkdirp устарел и его нужно обновить, но я не знаю как его обновить.
5f429285dd045837585066.png
В папки с так называемым проектом нечего не появилось.

Я попробовал иначе, как мне советовал один из пользователей форма Harb. Мне тогда пришлось его отметить как верное решение т. к. больше не кто не писал по этому поводу и хоть это и не было решением моей проблемы.
Вот ссылка на вопрос: "Почему не устанавливается expres?".
  • Вопрос задан
  • 41 просмотр
Решения вопроса 1
hzzzzl
@hzzzzl
В папки с так называемым проектом нечего не появилось


потому что npm i *module_name* -g устанавливает g-лобально на уровне системы, попробуй просто
npm i express-generator
Ответ написан
Пригласить эксперта
Ответы на вопрос 1
yarkov
@yarkov
Проект "Жизнь после смерти" - lifeafterdeath.ru
Мне кажется или это какой-то испанский стыд? WARN это предупреждение, а не ошибка. Судя по строчке updated 1 package in 1.545s всё прошло удачно ))
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы