webirus
@webirus
Тыжверстальщик! Наверстай мне упущенное...

Как устранить ошибки и битые пакеты?

$ sudo apt install npm
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
 npm : Зависит: nodejs но он не будет установлен
       Зависит: node-abbrev (>= 1.0.4) но он не будет установлен
       Зависит: node-ansi (>= 0.3.0-2) но он не будет установлен
       Зависит: node-ansi-color-table но он не будет установлен
       Зависит: node-archy но он не будет установлен
       Зависит: node-block-stream но он не будет установлен
       Зависит: node-fstream (>= 0.1.22) но он не будет установлен
       Зависит: node-fstream-ignore но он не будет установлен
       Зависит: node-github-url-from-git но он не будет установлен
       Зависит: node-glob (>= 3.1.21) но он не будет установлен
       Зависит: node-graceful-fs (>= 2.0.0) но он не будет установлен
       Зависит: node-inherits но он не будет установлен
       Зависит: node-ini (>= 1.1.0) но он не будет установлен
       Зависит: node-lockfile но он не будет установлен
       Зависит: node-lru-cache (>= 2.3.0) но он не будет установлен
       Зависит: node-minimatch (>= 0.2.11) но он не будет установлен
       Зависит: node-mkdirp (>= 0.3.3) но он не будет установлен
       Зависит: node-gyp (>= 0.10.9) но он не будет установлен
       Зависит: node-nopt (>= 3.0.1) но он не будет установлен
       Зависит: node-npmlog но он не будет установлен
       Зависит: node-once но он не будет установлен
       Зависит: node-osenv но он не будет установлен
       Зависит: node-read но он не будет установлен
       Зависит: node-read-package-json (>= 1.1.0) но он не будет установлен
       Зависит: node-request (>= 2.25.0) но он не будет установлен
       Зависит: node-retry но он не будет установлен
       Зависит: node-rimraf (>= 2.2.2) но он не будет установлен
       Зависит: node-semver (>= 2.1.0) но он не будет установлен
       Зависит: node-sha но он не будет установлен
       Зависит: node-slide но он не будет установлен
       Зависит: node-tar (>= 0.1.18) но он не будет установлен
       Зависит: node-underscore но он не будет установлен
       Зависит: node-which но он не будет установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.
  • Вопрос задан
  • 94 просмотра
Решения вопроса 1
webirus
@webirus Автор вопроса
Тыжверстальщик! Наверстай мне упущенное...
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы