Почему не запускается HelloWordl в Eclipse (Android)?

Здравствуйте, поставил Android Developmend tools с сайта google (Eclips)

Создаю проект:
Minimum Reguired SDK: 2.3.3
Target SDK: 2.3.3
Compile with: 2.3.3

Не пускает дальше Create Activity - This template requires a build target API version of at least 14, and the current version is 10.

Решил создать под 4.2.2

Выбрал: Minimum Reguired SDK: 4.2.2, Target SDK: 4.2.2, Compile with: 4.2.2

После чего ошибки:
Description	Resource	Path	Location	Type
The import android.support.v7.app cannot be resolved	MainActivity.java	/Project_1/src/ru/chvalov/project_1	line 3	Java Problem
ActionBarActivity cannot be resolved to a type	MainActivity.java	/Project_1/src/ru/chvalov/project_1	line 18	Java Problem
The method onCreate(Bundle) of type MainActivity must override or implement a supertype method	MainActivity.java	/Project_1/src/ru/chvalov/project_1	line 17	Java Problem
ActionBarActivity cannot be resolved to a type	MainActivity.java	/Project_1/src/ru/chvalov/project_1	line 14	Java Problem
The import android.support.v7.app cannot be resolved	MainActivity.java	/Project_1/src/ru/chvalov/project_1	line 4	Java Problem
The method setContentView(int) is undefined for the type MainActivity	MainActivity.java	/Project_1/src/ru/chvalov/project_1	line 19	Java Problem
The method getSupportFragmentManager() is undefined for the type MainActivity	MainActivity.java	/Project_1/src/ru/chvalov/project_1	line 22	Java Problem
The method onCreateOptionsMenu(Menu) of type MainActivity must override or implement a supertype method	MainActivity.java	/Project_1/src/ru/chvalov/project_1	line 30	Java Problem
The method getMenuInflater() is undefined for the type MainActivity	MainActivity.java	/Project_1/src/ru/chvalov/project_1	line 33	Java Problem
The method onOptionsItemSelected(MenuItem) of type MainActivity must override or implement a supertype method	MainActivity.java	/Project_1/src/ru/chvalov/project_1	line 38	Java Problem
ActionBarActivity cannot be resolved to a type	MainActivity.java	/Project_1/src/ru/chvalov/project_1	line 46	Java Problem


При этом Эмулятор даже не пытается запуститься, как решить данную проблему?

П.С. (Android developer tools - Build: v22.6.2-1085508)
  • Вопрос задан
  • 6315 просмотров
Решения вопроса 1
@Axeles
Нечего тут пока писать
На сайте startandroid.ru давно решили эту проблему. Там всё подробно описано. Советую Вам обратится туда.
Ответ написан
Пригласить эксперта
Ответы на вопрос 2
@Axeles
Нечего тут пока писать
Это разработчики так постарались!!! Теперь минимум API это 14 под Андройд если я не ошибаюсь 4.0. Есть два способа решения этой ситуации 1 -Скачать старый SDK и не обновлять, Второй зайти в файл XML и вручную изменить минимальную версию API. Вообще с новым обновлением для неопытных пользователей большие проблемы возникли я 2 дня ковырялся
Ответ написан
VYakushev
@VYakushev
Разработчик Android в Nowtaxi
Во-первых, если есть такая возможность, то лучше выкинуть Eclipse и поставить Android Studio с того же сайта Google, где брали SDK
А во-вторых, убедитесь что добавили все необходимые зависимости в настройках проекта. Ну, и неплохо было бы показать код MainActivity.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
05 авг. 2020, в 15:56
3000 руб./за проект
05 авг. 2020, в 15:31
3000 руб./за проект
05 авг. 2020, в 16:26
1000 руб./за проект