@webviktor

Как организовать фильтрацию трафика по странам в микротик?

Приветствую.

Есть список с адресами стран Здесь
Железка hap ac2 с белым ип и куча задолбавших скамеров, спареров, ботов и пр.
Файл с адресами отфильтрованных стран весит 7 мб.
В адрес лист такой если и пролезет, то кусками и долго.
Так же есть подозрение, что работать тик после этого будет очень медленно (если вообще будет).
Соотв. вопрос - можно ли подгружать данный список например из локального сервера или подключенной флешки ?
Возможно есть другой вариант реализации?

Спасибо
  • Вопрос задан
  • 247 просмотров
Пригласить эксперта
Ответы на вопрос 3
poisons
@poisons
Так ты фильтруй в другую сторону. Тебе кто нужен? РФ, СНГ? Вот и подгружай эти списки адресов.
Ответ написан
karabanov
@karabanov
Администрирую сети
Как вариант несколько идей можно почерпнуть отсюда https://www.youtube.com/watch?v=wGDTWaDL8jc
Ответ написан
@gav_cat
Я сделал так:
Гружу скриптом по планировщику раз в сутки список только RU адресов.
В адрес лист добавляется ~7700 записей
Дальше в фаерволе либо RU либо !RU.
Тормозов не заметил. У меня blacklist ~5000 записей.

/system scheduler
add interval=1d name=ADD_RU_ZONE on-event=\
"/system script run RU_zone\r\
\n" policy="ftp,reboot,read,write,policy,test,password,s\
niff,sensitive,romon" start-date=apr/10/2020 \
start-time=13:00:00
/system script
add dont-require-permissions=no name=RU_zone owner=admin \
policy="ftp,reboot,read,write,policy,test,password,sniff\
,sensitive,romon" source="/tool fetch url=\"http://www.i\
wik.org/ipcountry/mikrotik/RU\" mode=http\r\
\nimport RU"
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы