@Tempest99

Правильно ли я подключил jquery к WordPress через cdn?

В файл function.php прописал такой код
add_action( 'wp_enqueue_scripts', 'my_scripts_method' );
function my_scripts_method() {
	
	wp_deregister_script( 'jquery-core' );
	wp_register_script( 'jquery-core', '//ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js');
	wp_enqueue_script( 'jquery' );
}


и в header.php в тег head прописал такие строчки
<script type='text/javascript' src='//ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js'></script>
   <script type='text/javascript' src='http://example.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.2.1'></script>


Верно ли я сделал? Я подключил самую последнюю версию jquery и как проверить подключился ли он?
  • Вопрос задан
  • 38 просмотров
Пригласить эксперта
Ответы на вопрос 3
Kozack
@Kozack Куратор тега WordPress
и в header.php в тег head прописал такие строчки

И зачем?
Ещё раз перечитайте статью

Я подключил самую последнюю версию jquery

Заменять версию используемую в ВП по умолчанию — не всегда хорошая идея

как проверить подключился ли он?

Как проверить подключен ли jquery??! Это как-то слишком глупый вопрос. А если не знаете — погуглите.
Ответ написан
mediol-name
@mediol-name
Developer
Во-первых: по умолчанию lquery уже подключен к WordPress. Заново подключать стоит только в том случае, если вам действительно нужна новейшая версия для нестандартных решений.

Во-вторых: после того, как вы все правильно прописали в файле function.php строка в header.php появится САМОСТОЯТЕЛЬНО!
Ответ написан
OtshelnikFm
@OtshelnikFm Куратор тега WordPress
Мои работы: otshelnik-fm.ru
Подключив jQuery с CDN вы с вероятностью в 99% получите конфликт с сторонними плагинами.
По кодексу вордпресс эта библиотека должна быть подключена через ядро.
Я вижу что у вас на простом вопросе затык возник - значит и дальше все пойдет не так. Вы не понимаете что делаете и это беда.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы