@Tokenchik

Как правильно указать зависимости своего пакета?

Всем привет.
У меня есть один небольшой пакет для laravel, внутри него используются следующие зависимости:
"require-dev": {
    "orchestra/testbench": "^6.0@dev",
    "phpunit/phpunit": "^8.0"
},

Ci прогоняет тесты для версий php 7.2-7.3. Для 7.3 все проходит ок, однако для 7.2 тесты стали падать с ошибкой

Your requirements could not be resolved to an installable set of packages.
Problem 1
- Installation request for laravel/framework 8.x-dev -> satisfiable by laravel/framework[8.x-dev].
- laravel/framework 8.x-dev requires php ^7.3 -> your PHP version (7.2.15) does not satisfy that requirement.
Problem 2
- Installation request for laravel/framework dev-master -> satisfiable by laravel/framework[dev-master].
- laravel/framework dev-master requires php ^7.3 -> your PHP version (7.2.15) does not satisfy that requirement.
Problem 3
- Installation request for orchestra/testbench 6.0.x-dev -> satisfiable by orchestra/testbench[6.0.x-dev].
- orchestra/testbench 6.0.x-dev requires php >=7.3 -> your PHP version (7.2.15) does not satisfy that requirement.
Problem 4
- Installation request for orchestra/testbench dev-master -> satisfiable by orchestra/testbench[dev-master].
- orchestra/testbench dev-master requires php >=7.3 -> your PHP version (7.2.15) does not satisfy that requirement.
Problem 5
- Installation request for orchestra/testbench-core 6.0.x-dev -> satisfiable by orchestra/testbench-core[6.0.x-dev].
- orchestra/testbench-core 6.0.x-dev requires php >=7.3 -> your PHP version (7.2.15) does not satisfy that requirement.
Problem 6
- Installation request for orchestra/testbench-core dev-master -> satisfiable by orchestra/testbench-core[dev-master].
- orchestra/testbench-core dev-master requires php >=7.3 -> your PHP version (7.2.15) does not satisfy that requirement.

Ошибка появилась как раз после добавления секции require-dev, подскажите как правильно указать версию используемых пакетов для тестирования, чтобы продолжать использовать пакет в проектах с версией 7.2
  • Вопрос задан
  • 67 просмотров
Решения вопроса 1
neuotq
@neuotq
full stack php, стартапы, прокрастинация
Прочитав комментарии, заметил что вы слишком жестко указали версию php.
Лично я советую сатвить как можно меньшую (со знаком больше либо ровно), на которой конкретно ваш пакет будет работать.
Например, если конкретно ваш код, способен работать на 5.4, ставьте ее, возможно ваш пакет буду использовать на более старых системах. Естественно если есть прям зависимости ,которым нужно больше априори, то смысла в этом не будет. Но это считается хорошей практикой.
Те в вашем конкретном случае
"php": ">=7.2"
Но если есть, возможно ставьте "php": ">=5.4"
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы