@meridbt

Api vk.com — почему не принимает версию?

Если отправить запрос из песочницы, то сообщение успешно отправляется:
https://vk.com/dev/messages.send?params[random_id]=354655&params[peer_id]=185014513&params[message]=Test%20message&params[dont_parse_links]=0&params[disable_mentions]=0&params[v]=5.103

Если же перенести текст запроса в новую вкладку, добавив валидный токен...
https://api.vk.com/method/messages.send?params[random_id]=354654&params[peer_id]=185014513&params[message]=Test%20message&params[v]=5.103&access_token=валидный_токен_scope_messages

...то получаю сообщение об ошибке:
{"error":{"error_code":8,"error_msg":"Invalid request: v is required. Version param should be passed as \"v\". \"version\" param is invalid and not supported.","request_params":[{"key":"params","value":"354655,185014513,Test message,5.103"},{"key":"method","value":"messages.send"},{"key":"oauth","value":"1"}]}}
  • Вопрос задан
  • 132 просмотра
Решения вопроса 1
@Jasur0090
https://api.vk.com/method/messages.send?random_id=354654&peer_id=185014513&message=Testmessage&v=5.103&access_token=xxx

просто уберите params[] везде.
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы