@goodman77707

Что вы делаете в своих приложениях, если?

API бекенда изменилось, а старые версии приложения не загружают нужные данные, и не все пользователи обновились до последней версии?
Вы при запуске приложения показываете экран о том, что вышла новая версия и требуете ее установить, не давая возможности пользоваться старой версией?
  • Вопрос задан
  • 135 просмотров
Решения вопроса 2
Лично у нас в апи запросе от приложения указывается и версия апи, на сервере поддерживаем последние три версии, поэтому обновление происходит абсолютно гладко.
Ответ написан
@enginegl
Также можно использовать библиотеку Play Core от Google, которая позволяет реализовать принудительное обновление пользователей до новой версии:
https://developer.android.com/reference/com/google...
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
AGIMA Москва
от 170 000 ₽
S2 | CRM Тольятти
от 120 000 до 200 000 ₽
WD
от 150 000 ₽
04 апр. 2020, в 09:54
1000 руб./за проект
04 апр. 2020, в 07:02
1000 руб./в час