@belyaevcyrill

Как филиальным Микротикам подключаться к WAN головного Микротика через провайдера с динамическим IP?

Ситуация следующая...
Есть Микротик в головном офисе с четырьмя интернет-провайдерами, которые заменяют другу друга, если какой-то из них падает. Первый провайдер у этого Микротика со статикой, а остальные с динамикой (PPPoE). А также есть филиальные Микротики со статическими адресами 1.2.3.4, 5.6.7.8, и так далее. Таких филиальных Микротиков много.

Для связи между Головным офисом и филиалами поднят PPTP-туннель. Пока что головной Микротик использует для PPTP-туннеля IP-адрес интернет-провадера со статикой.

Как филиальным Микротикам автоматически установить PPTP-туннель с Микротиком головного офиса, если у Микротика головного офиса ляжет провайдер со статикой? Останутся три провайдера с динамикой. Но как филиальные Микротики узнают о их динамическом IP-адресе ? Есть ои какой-то простой способ оповестить филиальные Микротики о динамическом IP провайдера?
  • Вопрос задан
  • 3152 просмотра
Пригласить эксперта
Ответы на вопрос 8
Oxyd
@Oxyd
Linux enthusiast
Использовать Dynamic DNS и обращаться по доменным именам.
Ответ написан
@vadimbn
Системный администратор, директор микропредприятия
Все гораздо проще. Включите cloud-службу mikrotik - IP → Cloud →DDNS. Получите имя, основанное на серийном номере устройства (способ не будет работать в случае RouterOS x86). Это имя прописываете в качестве PPTP- сервера на филиальных роутерах. Это все, что нужно сделать. Изменился IP головного офиса - разорвалось соединение, но имя автоматически будет переназначено на новый IP, и филиалы автоматически переподключатся.
Ответ написан
@vladgorodetsky9
Включаем на роутерах.
Winbox -> IP -> Cloud -> DDNS Enabled - включаем. DNS Name дальше нам понадобится.
System -> Scripts -> Создаем скрипт. Далее пример для EoIP туннеля.

# Здесь мы получаем IP по DNS имени главного роутера.
:local WANLocale [:resolve **********.sn.mynetname.net]
# Получаем локальный адрес из EoIP туннеля. Туннель определяем по id
:local IPSLocal [/interface eoip get [/interface eoip find tunnel-id="15" ] local-address]
# Здесь мы получаем IP по DNS имени филиального роутера.
:local WANRemote [:resolve **********.sn.mynetname.net]
# Получаем удаленный адрес из EoIP туннеля. Туннель определяем по id
:local IPSRemote [/interface eoip get [/interface eoip find tunnel-id="15" ] remote-address]
# Дальше сравниваем полученные выше IP и меняем их, если они поменялись.
if ($WANLocal != $IPSLocal) do={
/interface eoip set [/interface eoip find tunnel-id="15"] local-address=[:resolve **********.sn.mynetname.net]
}
if ($WANRemote != $IPSRemote) do={
/interface eoip set [/interface eoip find tunnel-id="15"] remote-address=[:resolve **********.sn.mynetname.net]
}

Скрипт загоняем в шедулер, стартуем каждую минуту.

На филиальных аналогично, только подставляем DNS name наоборот. Там где главный - пишем филиальный, там где филиальный - главный.

Второй пример, для PPTP.
Его надо делать только на филиалах. Комментировать не буду, думаю с примера выше все понятно.
Используем только DNS name главного роутера, интерфейс находим по комментарию
:local WANRemote [:resolve **********.sn.mynetname.net]
:local IPSRemote [/interface pptp-client get [/interface pptp-client find comment="Alex" ] connect-to]
if ($WANRemote != $IPSRemote) do={
/interface pptp-client set [/interface pptp-client find comment="Alex"] connect-to=[:resolve **********.sn.mynetname.net]
}

Удачи
Ответ написан
@Igorjan
Если у филиальных микротиков статика, поднимайте туннели с головного к ним
Ответ написан
@Serkap
Универсал
Лучше свой поднять DNS, есть хороший вариант всегда стабильный это dns от yandex. По api мгновенно меняется.
Ответ написан
exorka
@exorka
Программист, админ, радиолюбитель
На главном роутере в расписание добавить скрипт который будет дергать URL какого то своего хостинга, а там писать IP, ведомые роутеры так же с помощью скриптов могут запрашивать этот IP. Но опять же этот вариант, если есть свой веб хостинг, не нужно платить за DynDNS.
Ответ написан
@Ivan_65536
По поводу динамики у юрика. Я тоже так думал, что всегда должна быть статика. Мол само самой разумеющееся.
Ан, нет! Бухгалтерским конторам и всяким продавашкам типа риэлтеров и прочей нечести пишушим объявления на площадках нужна динамика. Их банят. Они выбрали самвый простой способ - динамика и перезагрузка роутера.

Столкнулся с этим, когда переезжал сервер и для обсуживающей бухгалтерской фирмы пришлось поднимать vpn вместо классического фильтра на их адрес.
Ответ написан
@tr0jan4ik
Это вполне стандартная ситуация. Например на ряде контор что я обслуживанию именно такая же. Я использую оспф и стоимости маршрутов, а туннели поднимаю через всех провайдеров. Ну с динамическими айпи конечно дднс.
По поводу оповещения, можно использовать на головном офисе скрипт пингующий все ваши клиенты определенным колвом байтов, например 1000. Клиенты исходя из прилетающих ицмп запросов помещаю айпишники в определенный адрес лист. Дальше только ваша фантазия:)
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы