@pcdesign

Как получить приложения не старше определенной версии?

Есть у меня старенький ipad с IOS 6.0
Обновить его уже нельзя, но он работает.
Проблема с поиском совместимых со "старичком" приложений в апсторе.
Приходится тыкать, получать отлуп, идти дальше, спустя какое-то время находится совместимое приложение.
5e26f7684bab4318140751.png
Вопрос, есть ли возможность как-то отсортировать на апсторе все приложения не старше определенной версии?
Чтобы я на компе уже заранее видел какое приложение мне нужно ставить. И я его через поиск найду и поставлю.
  • Вопрос задан
  • 75 просмотров
Решения вопроса 1
@pcdesign Автор вопроса
Вот несколько строк на python.
Выдергиваем из апстора старенькие приложения, которые были зарелизены до 2012 года и содержат слова
puzzle

import requests
from dateutil.parser import parse

SEARCH = 'puzzle'
YEAR = 2012

url = f'https://itunes.apple.com/search?term={SEARCH}&limit=10000&media=software'
res = requests.get(url).json()
for item in res.get('results'):
    date_release = item.get('currentVersionReleaseDate')
    dt = parse(date_release)
    if YEAR >= dt.year:
        print(item.get('trackViewUrl'))

Ответ:
https://apps.apple.com/us/app/whats-my-iq/id547094449?uo=4
https://apps.apple.com/us/app/amazing-breaker-free/id448129309?uo=4

Документация к API здесь:
https://developer.apple.com/library/archive/docume...
Там можно более сложные составлять запросы.
Примеры
https://developer.apple.com/library/archive/docume...

Плюс в ответе приходит поле supportedDevices, по нему тоже можно дополнительно искать.
Ответ написан
Пригласить эксперта
Ответы на вопрос 1
prrrrrrr
@prrrrrrr
Верстаю сразу на PHP.
такая же беда когда-то с айфоном 4 была. не, нету
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы