Ruslan-Strannik
@Ruslan-Strannik
странствующее животное

Как правильно настроить очереди в Mikrotik?

Настраиваю queues в Микротик с использованием pcq. не могу понять один момент.
В параметрах queues type есть limit и Total limit. Что они делают?
Читаю офф документацию и мне не ясно )) туговат видимо.
Сейчас применяются значения по дефолту. Полез я читать про эти значения, дабы понять как уменьшить количество дропов.
В моем понимании - кьюс смотрит проходящий трафик и, если поток выше положенного, притормаживает пакеты, выстраивая их в очередь. Если так называемый бункер для очереди переполняется - вновь прибывшие пакеты уничтожаются.

Как увеличить размер этого бункера и какой параметр за это отвечает?
спасибо
  • Вопрос задан
  • 3446 просмотров
Решения вопроса 2
@BcTpe4HbIu
Если имеются в виду параметры pcq-limit и pcq-total-limit, то это размеры подочередей пакетов которые будут ждать отправки, если превышено ограничение. Соответственно pcq-limit - размер каждой подочереди, pcq-total-limit - общее ограничение на все подочереди.

Обычно дропы пакетов это нормально для какой-то части трафика (веб браузер например). Если есть какой то трафик для которого не желательны дропы (sip например) - нужно вынести его в отдельную очередь и поставить приоритет ~0-3.
Ответ написан
Ruslan-Strannik
@Ruslan-Strannik Автор вопроса
странствующее животное
pcq-limit размер в килобайтах для каждой подочереди. 1 подочередь = 1 dst address
если поставить галочку на dst port, то 1 подочередь = 1 dst address+1dst port
pcq-total limit размер в килобайтах - значение, по достижении которого вновь приходящие пакеты отбрасываются.
даже если у вас во всей очереди всего одна подочередь - все равно она не выйдет за рамки своих 50Kib(знач.Limit)
При этом все пакеты очередей хранятся в оперативке. Стоит это учитывать при выставлении больших значений Limit.
для себя выявил оптимальные параметры 300 и 20000.
далее решил использовать параметры Total в simple queue. Так как ширина канала 10 Мбит, то без этого никуда. Поправьте, если ошибаюсь.
и для него создал queue type
получилось вот такая схемка

/queue type
add kind=pcq name="type 1" pcq-classifier=src-address,dst-address \
pcq-limit=500KiB pcq-total-limit=40000KiB
set 6 pcq-limit=500KiB pcq-total-limit=20000KiB
set 7 pcq-limit=500KiB pcq-total-limit=20000KiB
/queue simple
add name=LAN queue=pcq-upload-default/pcq-download-default target=\
bridge1,bridge_guest total-max-limit=10M total-priority=3 total-queue=\
"type 1"
Пока не ясно как ведет себя queue type на вкладке advanced при наличии total-queue-type.

За сутки дропов пакетов не было. свободная память ниже 90Мб не опускалась, проц нагрузка на 15-35%.
Устройство RB951G-2HnD , в сети 15-20 устройств на офис 10 человек.
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы