@Pavel_Krotov

Cisco Nat load balancing + VRF. Как заставить работать ip nat inside destination на VRF?

Все мы прекрасно знаем про возможность организации простой балансировки tcp сессий средствами NAT Destanation на роутере Cisco.
https://habr.com/ru/post/108978/

Но вот потребовалось "Cisco Nat load balancing" настроить на VRF, и оказывается, что нет параметра VRF в командах ip nat inside destination...
Как же заставить работать работать Cisco Nat load balancing + VRF вместе?

ip access-list extended CISCO-NAT-LB
permit tcp any host 5.5.5.5 eq 80 443 <-Внешние IP

ip nat pool CISCO-NAT-LB 10.1.1.1 10.1.1.2 netmask 255.255.255.0 type rotary <-Внутреннние IP серверов, на кого балансировать.
ip nat inside destination list CISCO-NAT-LB pool CISCO-NAT-LB

interface GigabitEthernet0/0.22
ip vrf forwarding VRF1
ip nat outside
ip address 172.1.1.2 255.255.255.0

interface GigabitEthernet0/0.23
ip vrf forwarding VRF1
ip nat inside
ip address 172.1.2.2 255.255.255.0
  • Вопрос задан
  • 211 просмотров
Пригласить эксперта
Ответы на вопрос 2
vvpoloskin
@vvpoloskin
Инженер связи
На классическом ios вы должны сделать route leaking (статический маршрут в интерфейс в нужном vrf). NAT между vrf работает в ios-xe.
Но вашу задачу надо решать на отдельном балансере, это не работа маршрутизатора.
Ответ написан
@iddqda
уверен что не работает?
тут нужна поддержка VRF-Aware NAT т.е. несколько таблиц трансляций
циска знает что если пакет прилетел в интерфейс в VRF1 то и маршрутизировать и натить будет по соответствующим таблицам. Ничего в конфиг для этого отдельно прописывать не нужно.

И это старая фича. уже минимум лет 8 в IOS-ах такое реализовано

что за железяка?
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
07 июл. 2020, в 07:31
1000 руб./за проект
06 июл. 2020, в 23:49
10000 руб./за проект
06 июл. 2020, в 23:32
35000 руб./за проект