Как настроить в Mikrotik vpn подключение к серверам на aruba?

Доброго времени суток.
По понятным причинам понадобился зарубежный VPN. Обратил внимание на сервис aruba.
Настроил всё по мануалу - https://www.iphones.ru/iNotes/799076
Из Windows подключается, трафик идёт через Чехию. Всё отлично.

Раз всё работает, то решил перенести VPN-подключение на плечи роутера RB951G-2HnD.
Роутер имеет адрес 192.168.1.1
В Interface создаётся подключение L2TP Client. Указал сервер, логин, пароль, ipsec. Add Default Route включал/отключал. Судя по статусу подключение устанавливается, но трафик идёт всё равно мимо.
В NAT добавляю правило
action=masquerade chain=srcnat out-interface=l2tp-out1
. На всякий случай правило ставлю первым. Всё равно нет активности.
5ae0ba21544f7276253115.jpeg

И никак не могу понять, как пустить весь трафик (для начала) через VPN. В перспективе только бы определённые адреса через VPN открывал. Может инструкция по поднятию VPN нужна другая? Например, надо поднимать OpenVPN Server или ещё что-то...
  • Вопрос задан
  • 3550 просмотров
Решения вопроса 1
@vcrank Автор вопроса
Не понимаю, почему решение от Максим не сработало.
Сделал чуть другие действия (статья в интернете) и заработало
Добавляем IP, который надо пропустить через тунель
/ip firewall address-list add address=178.63.151.224 list=vpn

Добавляем NAT через vpn-подключение, добавляем еще один маршрут по умолчанию через интерфейс l2tp-out1 (название вашего подключения) для пакетов с маркировкой vpn и указываем правило маркировки этих пакетов для IP-адресов из списка vpn:

/ip firewall nat add action=masquerade chain=srcnat out-interface=vpn-usa
/ip firewall mangle add action=mark-routing chain=prerouting dst-address-list=vpn new-routing-mark=vpn passthrough=no
/ip route add dst-address=0.0.0.0/0 gateway=l2tp-out1 routing-mark=vpn
Ответ написан
Комментировать
Пригласить эксперта
Ответы на вопрос 2
jawakharlal
@jawakharlal
tools-ping - оттуда смотри работает ли канал или нет
и еще как вариант 0.0.0.0/0 eth1 дистанс 2 установите (ну это не 100%)
Ответ написан
gh0st_max
@gh0st_max
Слесарь по ремонту ПК
Посмотри статью https://habr.com/post/337426/

Хороший комент от AcidVenom 10.09.17 в 23:36
Это помечает соединение
/ip firewall mangle add chain=prerouting src-address=192.168.0.0/24 dst-address-list=AnotherGWList action=mark-routing new-routing-mark=AnotherGWRoute

Это маршрут для помеченных
/ip route add distance=1 routing-mark=AnotherGWRoute gateway=*ваш_GW*

Ну а это — ресурс, который нужно маршрутизировать через нужный шлюз.
/ip firewall address-list add address=linkedin.com list=AnotherGWList

Далее просто добавляете нужный ресурс в адресные листы с именем AnotherGWList.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы