serii81
@serii81
Я люблю phр...

Как побороть ошибку при установке yii2 через composer?

Первый раз устанавливаю yii2.
С токенами разобрался, теперь осталось решить проблему с зависимостями
composer create-project yiisoft/yii2-app-basic 2.0.12                                                          ──(Ср,окт11)─┘
Installing yiisoft/yii2-app-basic (2.0.12)
  - Installing yiisoft/yii2-app-basic (2.0.12): Loading from cache
Created project in 2.0.12
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - yiisoft/yii2 2.0.9 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.8 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.7 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.6 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.5 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.12 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.11.2 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.11.1 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.11 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
    - yiisoft/yii2 2.0.10 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable | 1.12.*@stable -> no matching package found.
    - Installation request for yiisoft/yii2 ~2.0.5 -> satisfiable by yiisoft/yii2[2.0.10, 2.0.11, 2.0.11.1, 2.0.11.2, 2.0.12, 2.0.5, 2.0.6, 2.0.7, 2.0.8, 2.0.9].

Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your minimum-stability setting
   see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.

Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.

Как именно решить проблему? Дело в том, что начал изучения курса по yii2, у препода все благополучно установилось, а у меня косяки, хотя код взял с оф сайта yii.
Может из-за этого проблема?
{
    "require": {
        "fxp/composer-asset-plugin": "^1.2.0"
    }
}

Заранее благодарен.
  • Вопрос задан
  • 2092 просмотра
Решения вопроса 1
NataliTimofeeva
@NataliTimofeeva
Your requirements could not be resolved to an installable set of packages.

Не все установили. Видео с подсказками здесь https://youtu.be/vuxB2vaZWAU?t=1m5s
Ответ написан
Пригласить эксперта
Ответы на вопрос 1
serii81
@serii81 Автор вопроса
Я люблю phр...
Заработало, вот ссылка на решение https://stackoverflow.com/questions/23083045/the-p...
Оказывается, что нужно было прописать composer create-project yiisoft/yii2-app-basic 2.0.12 -sdev
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы