@gmg

Не чего не устанавливает apt-get?

Ребят помогите справиться с проблемой.

Debian 7

root@lh:~# apt-get install php5
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: The package libc6 needs to be reinstalled, but I can't find an archive for it.


Что бы я не устанавливал выдает данную строчку. А как установить этот пакет libc6, не знаю.
И вообще что мне прочитать информацию, чтобы понять что такое apt-get чтобы не было проблем с установкой ПО на линукс. Спасибо.
  • Вопрос задан
  • 624 просмотра
Пригласить эксперта
Ответы на вопрос 4
GavriKos
@GavriKos
И вообще что мне прочитать информацию, чтобы понять что такое apt-get чтобы не было проблем с установкой ПО на линукс.

man apt-get
Ответ написан
@antonsr98
Системный Администратор
sudo apt update && sudo apt upgrade или sudo apt-get update && sudo apt-get upgrade
затем sudo apt install php5 или sudo apt-get install php5
Ответ написан
Для начала надо удалить неустановленный пакет sudo apt-get remove libc6, иначе вы не сдвинетесь дальше
затем уже sudo apt-get update $$ sudo apt-get upgrade - проведете обновление пакетов
А затем уже попробуйте установить php
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы