n-name
@n-name

Как исправить ошибку в Vagrant (not find compatible versions for gem "nokogiri")?

Добрый день.
Linux Ubuntu 16.04. Vagrant (1.8.0) при старте

$ sudo vagrant plugin list
ffi (1.9.18)
nokogiri (1.6.3.1)
vagrant-share (1.1.6, system)
vagrant-vbguest (0.13.0)


$ sudo vagrant up --provider libvirt
The provider 'libvirt' could not be found, but was requested to
back the machine 'default'. Please use a provider that exists.


$ sudo vagrant plugin install libvirt
The plugin(s) can't be installed due to the version conflicts below.
This means that the plugins depend on a library version that conflicts
with other plugins or Vagrant itself, creating an impossible situation
where Vagrant wouldn't be able to load the plugins.

You can fix the issue by either removing a conflicting plugin or
by contacting a plugin author to see if they can address the conflict.

Vagrant could not find compatible versions for gem "nokogiri":
  In Gemfile:
    vagrant (= 1.8.0) ruby depends on
      nokogiri (= 1.6.3.1) ruby

    libvirt (>= 0) ruby depends on
      nokogiri (~> 1.4.3) ruby

    nokogiri (>= 0) ruby
  • Вопрос задан
  • 285 просмотров
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
от 100 000 до 200 000 ₽
AI People Санкт-Петербург
от 100 000 ₽
Абсолют Банк Москва
от 150 000 до 170 000 ₽
28 мая 2020, в 19:04
4000 руб./за проект
28 мая 2020, в 18:31
1000 руб./за проект
28 мая 2020, в 18:28
15000 руб./за проект