Сеть дом и офис

Всем привет, помогите разобраться.
Есть:
Работа: Сервер 2003+Керио с внешним IP, сеть 10.10.200.0
Дом: Роутер Mikrotik 751u сеть 192.168.88.0
Нужно иметь доступ в обе стороны, что бы с дома можно было зайти на любой компьютер сети и наоборот.
На данный момент я подключился через VPN клиент роутера к серверу через стандартное подключение, у меня доступ в рабочую сеть есть, а обратно нет.
Как все правильно сделать? Спасибо!
  • Вопрос задан
  • 9394 просмотра
Решения вопроса 1
@vip-zaec
На Kerio создается vpn-тоннель - тип подключения "Активное", с авторизацией по предопределенному ключу.
локальный id- произвольное имя kerio
отдаленный id - внешний ip на mikrotik

1.png

удаленные сети - 192.168.88.0/24 (домашняя за mikrotik)

2.png

локальные сети - сеть, за kerio, та что в офисе

3.png

На mikrotik'е необходимо открыть порты, выполнив следующие команды:

/ip firewall filter add chain=input comment="Allow IKE" dst-port=500 protocol=udp
/ip firewall filter add chain=input comment="Allow IPSec-esp" protocol=ipsec-esp
/ip firewall filter add chain=input comment="Allow IPSec-ah" protocol=ipsec-ah
/ip firewall filter add chain=input comment="Allow UDP" protocol=udp

На вкладке ip->Firewall появятся 4 новых правила:
4.png

Настраиваем Proposals (ip->ipsec-Proposals)

/ip ipsec proposal set [ find default=yes ] enc-algorithms=3des,aes-128 pfs-group=none

5.png

Настраиваем peer (adress - внешний ip kerio, password - предопределенный ключ авторизации, как в настройках vpn на kerio):

/ip ipsec peer add address=195.138.xxx.xxx/32 dh-group=modp1536 exchange-mode=main-l2tp generate-policy=port-override hash-algorithm=sha1 passive=yes secret=password

6.png

После этого должен подняться тоннель.
Для прохождения трафика между офисной и домашней сетью, необходимо добавить правило

/ip firewall nat add chain=srcnat dst-address=10.10.10.0/24 src-address=192.168.88.0/24

(Сеть 10.10.10.0/24 в примере - офисная сеть, за kerio
192.168.88.0/24 - домашняя сеть, за mikrotik)
Ответ написан
Пригласить эксперта
Ответы на вопрос 3
@1x1
Добавить на сервере маршрут на домашнюю сеть через PPTP интерфейс.
Ответ написан
WAYS
@WAYS Автор вопроса
Спасибо! Но не вышло, перепробовал множество вариантов, но доступа к 192.168.88.0 так и не получил, даже с сервера (возможно нужно что-то еще настраивать в роутере). Но удалось получить доступ к IP vpn клиента с сети предприятия (роутеру дома), что уже радует.

image
192.168.88.1 Роутер
192.168.88.252 Компьютер
Ответ написан
@angelform
Сисьадмин
у меня exchange-mode=main-l2tp отсутствует
есть только main, aggressive,base
как-то добавить надо? или у меня версия ОС не та?
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы