@dick1997

Как на cisco изменить трансляцию сетевых адресов при изменении провайдера?

Добрый день, есть два провайдера, у одного из них пул из 2-х адресов(10.10.10.102-103), у второго 1-н(11.11.11.2), для одного из серверов выделен адрес и настроен pool для этого адреса
ip nat pool ISP103 10.10.10.103 10.10.10.103 netmask 255.255.255.248
ip nat pool ISP1 10.10.10.102 10.10.10.102 netmask 255.255.255.248
ip nat pool ISP2 11.11.11.2 11.11.11.2 netmask 255.255.255.248

сделан список для этого сервера и общий
ip access-list extended Server_ISP1
permit ip host 192.168.0.6 any
ip access-list extended Server_ISP2
permit ip host 192.168.0.6 any

ip access-list extended NAT
deny ip host 192.168.0.6 any
permit ip 192.168.0.0 0.0.255.255 any

настроена карта маршрутов
route-map ISP2_NAT permit 10
match ip address NAT
match interface GigabitEthernet0/0/0
!
route-map ISP1_NAT permit 10
match ip address NAT
match interface GigabitEthernet0/0

и настроен NAT
ip nat inside source list Server_ISP1 pool ISP103
ip nat inside source list Server_ISP2 pool ISP2

ip nat inside source route-map ISP1_NAT pool ISP1 overload
ip nat inside source route-map ISP2_NAT pool ISP2 overload

настроены маршруты, с проверкой основного провайдера
ip route 0.0.0.0 0.0.0.0 10.10.10.101 track 1
ip route 0.0.0.0 0.0.0.0 11.11.11.1 10

настроена очистка трансляции при срабатывании track 1
event manager applet ISP_Clear_session
event track 1 state any
action 001 cli command "enable"
action 002 cli command "clear ip nat trans force"

но при проблеме с оновным с провайдером при проверке "sh ip nat translations" рансляция с правила "ip nat inside source list Server_ISP1 pool ISP103" сохраняется и интернет на том Server не появляется, если убрать это правило "no ip nat inside source list Server_ISP1 pool ISP103" интернет появляется от второго провайдера, но перед удаением правила выходит предупреждение "Dynamic mapping in use, do you want to delete all entries?(Не удается удалить, так как динамическое распределение занято (используется))". как можно это исправить и сделать так чтобы server мог работать нормально меняя провайдеров в случае проблем с одним из них?
  • Вопрос задан
  • 549 просмотров
Решения вопроса 1
Saenara
@Saenara
Уберите совсем и навсегда
ip nat inside source list Server_ISP1 pool ISP103
ip nat inside source list Server_ISP2 pool ISP2

Используйте для трансляции особенного адреса 192.168.0.6 тоже
ip nat inside source route-map ...
и будет вам счастье :-)

event manager applet тоже уберите.
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы