karabanov
@karabanov
Администрирую сети

Как стабилизировать Wi-Fi на MikroTik?

Привет.

Что не пробовал так и не смог заставить Wi-Fi на MikroTik RB951Ui-2HnD работать стабильно. Проблема в том, что по прошествии 10-12 минут траффик перестаёт ходить. Совсем. При попытке отключится/подключится снова SSID пропадает из эфира. Если несколько раз отключится/подключится, то Wi-Fi начинает работать стабильно снова минут 10 и т.д.
Все остальное работает стабильно, без накладок и сбоев и только Wi-Fi мешает мне жить.

Если к MikroTik подключить кабелем любой роутер или точку доступа (я подключал D-Link DIR-615 Rev. K1, Sagemcom v2407, Tp-Link TL-WR740n, ASUS RT-N12), и подключаться уже к ней, то никаких проблем не возникает, Wi-Fi работает часами. Перепробовав многое я заставил более менее стабильно работать Wi-Fi на ноутбуке, но вот телефон на Android по прежнему отключается через 1-12 минут (на работе, в кафе, да в любом другом месте все мои устройства работают с Wi-Fi стабильно).
Я бы конечно пользовался всеми вышеперечисленными роутерами, но мне нужет IPsec туннель до рабочего компьютера и прочие фишки MikroTik.
Поначалу думал, что проблема в зашумлённом эфире (вокруг меня было более 50 роутеров всех мастей), но нет, на новом адресе эфир чистый, всего три роутера рядом, а проблема такая же.

Есть идеи на счёт того, что я делаю не так.

Вот такой конфиг сейчас на моём MikroTik-ке:
# mar/25/2016 14:54:50 by RouterOS 6.34.3
# software id = KNDM-RWIV
#
/interface ethernet
set [ find default-name=ether1 ] name=ether1-gateway
set [ find default-name=ether2 ] name=ether2-master-local
set [ find default-name=ether3 ] master-port=ether2-master-local name=ether3-slave-local
set [ find default-name=ether4 ] name=ether4-slave-iptv-STB
set [ find default-name=ether5 ] master-port=ether2-master-local name=ether5-slave-local-PoE
/interface bridge
add name=bridge-iptv protocol-mode=none
add name=loopback0

/ip neighbor discovery
set ether1-gateway discover=no
set ether2-master-local discover=no
set ether3-slave-local discover=no
set ether4-slave-iptv-STB discover=no
set ether5-slave-local-PoE discover=no
set bridge-iptv discover=no

/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" group-key-update=1h mode=dynamic-keys wpa-pre-shared-key="werystrongkey" \
    wpa2-pre-shared-key="werystrongkey"
add authentication-types=wpa2-psk eap-methods="" group-key-update=1h mode=dynamic-keys name=Home-Wi-Fi supplicant-identity="" wpa2-pre-shared-key=\
    "werystrongkey"
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-onlyn bridge-mode=disabled channel-width=20/40mhz-Ce country=russia2 disabled=no disconnect-timeout=15s \
    frequency-mode=regulatory-domain mode=ap-bridge multicast-buffering=disabled multicast-helper=disabled preamble-mode=short security-profile=\
    Home-Wi-Fi ssid=Peresmeshnik update-stats-interval=5h wireless-protocol=802.11 wmm-support=enabled
/ip neighbor discovery
set wlan1 discover=no

/interface bridge port
add interface=ether2-master-local
add interface=wlan1
add bridge=bridge-iptv interface=ether1-gateway
add bridge=bridge-iptv interface=ether4-slave-iptv-STB

/system clock
set time-zone-name=Europe/Moscow
/system leds
set 5 interface=wlan1
/system logging
add topics=wireless,debug
/system ntp client
set enabled=yes primary-ntp=pool.ntp.org secondary-ntp=91.207.136.55


PS
В вопрос призывается @sizaik
В вопрос призывается Евгений Быченко
  • Вопрос задан
  • 20151 просмотр
Решения вопроса 1
karabanov
@karabanov Автор вопроса
Администрирую сети
Проблема была не в Wi-Fi. Проблема была в коротком Lease time.
Решение нашел здесь: Исправить баг/фичу роутера микротик?

PS
Ну есть и положительный момент. У меня теперь ультра стабильный Wi-Fi.
Ответ написан
Пригласить эксперта
Ответы на вопрос 4
ifaustrue
@ifaustrue
Пишу интересное в теллеграмм канале @cooladmin
Особо глаз ни за что в конфиге не зацепился, разве что за preamble-mode=short (поменять на both).
Обычно при таких странных случаях лучше сделать reset configuration (именно для беспроводного интерфейса, а не для всего роутера. Пункт доступен в интерфейсе через винбокс) и попробовать задать минимальные параметры: режим, канал, профиль безопасности. Бывает что постоянные модификации настроек интерфейса приводят к проблемам в их работе на уровне чипа, которые не видны в интерфейсе.
Ответ написан
Konstantin18ko
@Konstantin18ko
Стоматолог
Если память мне не изменяет, то WiFi можно забить каналы. Попробуйте взять самый низкий канал.
Ответ написан
morpheus25
@morpheus25
Системный администратор
Евгений Быченко не нашел через winbox ресет конфигурейшн беспроводного интерфейса... Можно подробнее описать?
Ответ написан
@aleksjr
Ребята кто возьмет садминистрировать мой домашний микротик: сделать стабильный wifi и + под серевер бекапов настроить?
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
S2 | CRM Тольятти
от 120 000 до 200 000 ₽
Oblako Studio Санкт-Петербург
от 120 000 до 240 000 ₽
от 120 000 до 200 000 ₽