EnterSandman
@EnterSandman
Эникей

Почему не встает модуль?

Доброго времени суток
пытаюсь установить amqp для php7 на centos 7.x
yum install php*amqp
получаю ошибку
php70w-common conflicts with php-common-5.4.16-36.el7_1.x86_64

верно ли я понимаю что такой пакет есть только для 5.4 или что не так?
заранее благодарю

upd вывод yum.

Resolving Dependencies
--> Running transaction check
---> Package php-pecl-amqp.x86_64 0:1.4.0-1.el7 will be installed
--> Processing Dependency: php(zend-abi) = 20100525-64 for package: php-pecl-amqp-1.4.0-1.el7.x86_64
--> Processing Dependency: php(api) = 20100412-64 for package: php-pecl-amqp-1.4.0-1.el7.x86_64
--> Running transaction check
---> Package php-common.x86_64 0:5.4.16-36.el7_1 will be installed
--> Processing Conflict: php70w-common-7.0.0-1.w7.x86_64 conflicts php-common < 5.5.0
--> Finished Dependency Resolution
Error: php70w-common conflicts with php-common-5.4.16-36.el7_1.x86_64
  • Вопрос задан
  • 849 просмотров
Решения вопроса 1
EnterSandman
@EnterSandman Автор вопроса
Эникей
отвечу сам
yum install rabbitmq-devel
pecl install amqp-1.7.0alpha1 //ибо тут добавили поддержку php7
Ответ написан
Пригласить эксперта
Ответы на вопрос 1
Fesor
@Fesor
Full-stack developer (Symfony, Angular)
верно ли я понимаю что такой пакет есть только для 5.4 или что не так?


У вас установлен пакет php-common-5.4.бла бла бла и с ним конфликтует php*amqp.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы