@TraiDeR

Почему Zyxel Keenetic Giga II теряет PPPoE?

Здравствуйте! Недавно обменял свой Zyxel Keenetic Giga 2 по гарантии на новый такой же. Менял в связи с регулярной потерей PPPoE соединения. В результате новый роутер ведет себя почти так же, изменились только интервалы потери соединения. Если раньше держал сессию максимум пару часов, то сейчас новый роутер держит около 12-18 часов, после чего обрыв и подключится не может достаточно долго, если переткнуть кабель в WAN порт, то устанавливает соединения практически сразу.
В этот момент в логах происходит следующее:
[E] Dec 29 19:45:46 ndm: Service: "PPPoE0" unexpectedly stopped.
[I] Dec 29 19:45:49 pppd[279]: Plugin rp-pppoe.so loaded.
[I] Dec 29 19:45:49 pppd[279]: pppd 2.4.4 started by root, uid 0
[I] Dec 29 19:45:49 pppd[279]: Found unterminated session: 26738:ac:85:3d:92:04:15
[I] Dec 29 19:45:49 pppd[279]: Sent PADT
[I] Dec 29 19:45:50 pppd[279]: PADS: Service-Name: ''
[I] Dec 29 19:45:50 pppd[279]: PPP session is 19379
[I] Dec 29 19:45:50 pppd[279]: using channel 4
[I] Dec 29 19:45:50 pppd[279]: Using interface ppp0
[I] Dec 29 19:45:50 pppd[279]: Connect: ppp0 <--> eth2.3006
[I] Dec 29 19:45:50 pppd[279]: sent [LCP ConfReq id=0x1 <mru 1492> <magic 0x8e69d636>]
[I] Dec 29 19:45:53 pppd[279]: rcvd [LCP ConfReq id=0x2 <mru 1492> <auth pap> <magic 0x5c8f5bd>]
[I] Dec 29 19:45:53 pppd[279]: sent [LCP ConfAck id=0x2 <mru 1492> <auth pap> <magic 0x5c8f5bd>]
[I] Dec 29 19:45:53 pppd[279]: sent [LCP ConfReq id=0x1 <mru 1492> <magic 0x8e69d636>]
[I] Dec 29 19:45:56 pppd[279]: sent [LCP ConfReq id=0x1 <mru 1492> <magic 0x8e69d636>]
[I] Dec 29 19:45:56 pppd[279]: rcvd [LCP ConfReq id=0x3 <mru 1492> <auth pap> <magic 0x5c8f0f6>]
[I] Dec 29 19:45:56 pppd[279]: sent [LCP ConfAck id=0x3 <mru 1492> <auth pap> <magic 0x5c8f0f6>]
[I] Dec 29 19:45:59 pppd[279]: rcvd [LCP ConfReq id=0x4 <mru 1492> <auth pap> <magic 0x5c80075>]
[I] Dec 29 19:45:59 pppd[279]: sent [LCP ConfAck id=0x4 <mru 1492> <auth pap> <magic 0x5c80075>]
[I] Dec 29 19:45:59 pppd[279]: sent [LCP ConfReq id=0x1 <mru 1492> <magic 0x8e69d636>]
[I] Dec 29 19:46:02 pppd[279]: rcvd [LCP ConfReq id=0x5 <mru 1492> <auth pap> <magic 0x5c8a218>]
[I] Dec 29 19:46:02 pppd[279]: sent [LCP ConfAck id=0x5 <mru 1492> <auth pap> <magic 0x5c8a218>]
[I] Dec 29 19:46:02 pppd[279]: sent [LCP ConfReq id=0x1 <mru 1492> <magic 0x8e69d636>]
[I] Dec 29 19:46:05 pppd[279]: rcvd [LCP ConfReq id=0x6 <mru 1492> <auth pap> <magic 0x5c8c69d>]
[I] Dec 29 19:46:05 pppd[279]: sent [LCP ConfAck id=0x6 <mru 1492> <auth pap> <magic 0x5c8c69d>]
[I] Dec 29 19:46:05 pppd[279]: sent [LCP ConfReq id=0x1 <mru 1492> <magic 0x8e69d636>]
[I] Dec 29 19:46:08 pppd[279]: rcvd [LCP ConfReq id=0x7 <mru 1492> <auth pap> <magic 0x5c8e9df>]
[I] Dec 29 19:46:08 pppd[279]: sent [LCP ConfAck id=0x7 <mru 1492> <auth pap> <magic 0x5c8e9df>]
[I] Dec 29 19:46:08 pppd[279]: sent [LCP ConfReq id=0x1 <mru 1492> <magic 0x8e69d636>]
[I] Dec 29 19:46:11 pppd[279]: rcvd [LCP ConfReq id=0x8 <mru 1492> <auth pap> <magic 0x5c8daa1>]
[I] Dec 29 19:46:11 pppd[279]: sent [LCP ConfAck id=0x8 <mru 1492> <auth pap> <magic 0x5c8daa1>]
[I] Dec 29 19:46:11 pppd[279]: sent [LCP ConfReq id=0x1 <mru 1492> <magic 0x8e69d636>]
[I] Dec 29 19:46:14 pppd[279]: rcvd [LCP ConfReq id=0x9 <mru 1492> <auth pap> <magic 0x5c89d7c>]
[I] Dec 29 19:46:14 pppd[279]: sent [LCP ConfAck id=0x9 <mru 1492> <auth pap> <magic 0x5c89d7c>]
[I] Dec 29 19:46:14 pppd[279]: sent [LCP ConfReq id=0x1 <mru 1492> <magic 0x8e69d636>]
[I] Dec 29 19:46:17 pppd[279]: rcvd [LCP ConfReq id=0xa <mru 1492> <auth pap> <magic 0x5c8bb44>]
[I] Dec 29 19:46:17 pppd[279]: sent [LCP ConfAck id=0xa <mru 1492> <auth pap> <magic 0x5c8bb44>]
[I] Dec 29 19:46:17 pppd[279]: sent [LCP ConfReq id=0x1 <mru 1492> <magic 0x8e69d636>]
[W] Dec 29 19:46:20 pppd[279]: LCP: timeout sending Config-Requests 
[I] Dec 29 19:46:20 pppd[279]: Connection terminated.
[I] Dec 29 19:46:20 pppd[279]: Sent PADT
[I] Dec 29 19:46:20 pppd[279]: Modem hangup
[I] Dec 29 19:46:20 pppd[279]: Exit.
[E] Dec 29 19:46:20 ndm: Service: "PPPoE0" unexpectedly stopped.

Тестировал с двумя другими роутерами, они держат сессию стабильно, без обрывов.
Конечно, проще всего опять отнести в магазин и сдать по гарантии, но уж больно нравится роутер, не знаю даже какую альтернативу выбрать. Возможно, кто-то сталкивался с такой проблемой или может кто поможет расшифровать логи и подскажет в каком направлении капать дальше, в чем причина такого поведения?

UPD: На данный момент проблема остается нерешенной. Поддержка ZyXEL говорит, что проблема с провайдером, так как в логах и дампе пакетов видно, что от провайдера не приходит ACK. Общался с поддержкой провайдера очень долго, они в своей сети проблем не обнаружили.
Чтобы отсеять проблемы с провайдером, решил подключить кабель в компьютер напрямую. VLAN'ы задал с помощью Realtek Diagnostic Utility. Соединение держится стабильно достаточно долго, однако, как только кабель вставляю обратно в Keenetic Giga 2 - постоянные обрывы. Сейчас сдал роутер по гарантии, пока Keenetic Giga 2 на экспертизе, мне выдали из подменного фонда Keenetic 4G. Этот роутер держит соединение уже 28 дней. На мой взгляд, винить провайдера не имеет смысла, альтернативное оборудование от того же ZyXEL работает стабильно, а вот Giga 2 подводит.
Подтверждение моих слов о том, что соединение активно 28 дней на Keenetic 4G:
5aab238d4a134b2589ab763c35920ab0.png
  • Вопрос задан
  • 13916 просмотров
Решения вопроса 1
@TraiDeR Автор вопроса
Отвечу сам. Обменяв два роутера Keenetic Giga II по гарантии. Третий роутер все-таки заработал. На третьем роутере обрывов не заметил. Скорее всего те два роутера - брак. Непонятно, почему поддержка ZyXEL винила провайдера, если с другими роутерами соединение держалось стабильно, а с Keenetic Giga 2 - нет. Очень много времени и нервов потратил на решение проблемы, но в конечно итоге все закончилось хорошо.
Если у кого-то будет похожая проблема, сразу сдавайте роутер в магазин и пишите претензию, в которой укажите дефект и требуйте обмена. В случае если продавец будет проводить экспертизу, рекомендую на это время потребовать у магазина предоставить роутер на замену. Будет возможность протестировать интернет с другим роутером.
Ответ написан
Пригласить эксперта
Ответы на вопрос 5
Попробуйте обратиться в поддержку Zyxel, sd.zyxel.ru там должны вам помочь.
Ответ написан
askeet
@askeet
У меня такая же модель роутера. Обрывы конечно же бывают но уж очень редко, обычно при грешил на качество канала с провайдером.
Про Zyxel Keenetic Giga II от себя скажу что заводская прошивка на нем менее юзабилина чем на моем прошлом , который остался у родителей Zyxel Keenetic II.
Ответ написан
@grafist02511
Я так понимаю, в зукселе все порты гигабитные? Другие роутреры, которые хорошо работают, тоже гигабитные порты? Быть может со стороны провайдера порт на коммутаторе 100мбит.
Ответ написан
Dee3
@Dee3
Пишу из будущего, 2019 год, Keenetic Viva, новейшая прошивка - такая же проблема.
Не уверен что замена устройства поможет и хочется все таки разобраться в чем причина.
Ответ написан
terronex
@terronex
junior devops
Присоединяюсь к Вашей дискуссии и "Keenetic DSL" также теряет PPPOE. Уже все перепробовал и все напрасно.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы