@aizhar777

Как решить ошибку Nuxt 3: does not provide an export named execa?

Появилась ошибка после обновления Nuxt, c 3.10.2 до 3.11.2.

Nuxt project info:                                                                       15:51:06

------------------------------
- Operating System: Linux
- Node Version:     v20.12.2
- Nuxt Version:     3.11.2
- CLI Version:      3.11.1
- Nitro Version:    2.9.6
- Package Manager:  npm@10.5.0
- Builder:          -
- User Config:      devtools, modules, css, tailwindcss, lodash, i18n, swiper, runtimeConfig
- Runtime Modules:  @pinia/nuxt@0.5.1, @nuxt/ui@2.15.2, @nuxt/image@1.6.0, @nuxtjs/tailwindcss@6.12.0, @nuxtjs/i18n@8.3.1, nuxt-swiper@1.2.2, nuxt-og-image@3.0.0-rc.52, nuxt3-leaflet@1.0.12, nuxt-lodash@2.5.3
- Build Modules:    -
------------------------------


Вод вывод ошибки:

frontend    | 
frontend    | > dev
frontend    | > nuxt dev
frontend    | 
frontend    | Nuxt 3.11.2 with Nitro 2.9.6
frontend    | 
frontend    |   ➜ Local:    http://0.0.0.0:3000/
frontend    |   ➜ Network:  http://172.19.0.4:3000/ [QR code]
frontend    |   ➜ Network:  http://172.21.0.2:3000/
frontend    | 
frontend    | 
frontend    | 
frontend    | [nuxt:tailwindcss] ℹ Using default Tailwind CSS file
frontend    | ℹ Re-optimizing dependencies because lockfile has changed
frontend    | ℹ Vite server warmed up in 29502ms
frontend    | ℹ Vite client warmed up in 37440ms
frontend    | [nitro] ✔ Nuxt Nitro server built in 8946 ms
frontend    | 
frontend    | 
frontend    | 
frontend    |  ERROR  [worker reload] [worker init] The requested module 'file:///src/node_modules/execa/index.js' does not provide an export named 'execa'
frontend    | 
frontend    |   import { execa } from 'node_modules/execa/index.js';
frontend    |   ^^^^^
frontend    |   SyntaxError: The requested module 'node_modules/execa/index.js' does not provide an export named 'execa'
frontend    |   at ModuleJob._instantiate (node:internal/modules/esm/module_job:134:21)
frontend    |   at async ModuleJob.run (node:internal/modules/esm/module_job:217:5)
frontend    |   at async ModuleLoader.import (node:internal/modules/esm/loader:323:24)
frontend    |   at async loadESM (node:internal/process/esm_loader:28:7)
frontend    |   at async handleMainPromise (node:internal/modules/run_main:113:12)


Удалял папку node_modules и package.json, полностью переустанавливая пакеты, не помогло.

В гугле к сожалению информацию не нашел
  • Вопрос задан
  • 96 просмотров
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы