seregazolotaryow64
@seregazolotaryow64
IT Специалист и самоучка

Как исправить предупреждение «Critical dependency: the request of a dependency is an expression» при подключении приложения на Expo SDK к SQLite?

В проекте на Expo SDK пытаюсь на все 100 интегрировать приложение с SQLLite и подключал я строго по инструкции. Тестируя внедрение в браузере, компилятор выдал вот такой сюрприз:
Critical dependency: the request of a dependency is an expression


Сам фрагмент кода, на который ругается компилятор:
await FileSystem.downloadAsync(
    Asset.fromModule(require(pathToDatabaseFile)).uri,
    FileSystem.documentDirectory + pathToDatabaseFile
  )
  return SQLite.openDatabase(pathToDatabaseFile)


Что это означает и как это исправить?

P.S.: Файлы кода с проблемными фрагментами по ссылке.
  • Вопрос задан
  • 34 просмотра
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы