@GadMin
Околокомпьютерный оболтус

Неизвестная ошибка при подключении SSD/HDD (Debian) — контроллер или софт?

Всем добрый.
SSD Crusial MX500 (NTFS) при подключении через переходник SATA-USB перестал монтироваться в системе (ElementaryOS 7.01). Один раздел, ОС не установлена, SSD использовался как большая флешка. Диск определяется, корректно. При монтировании диска в систему - вываливается плашка с сообщением "Неизвестная ошибка"
Через этот же переходник подключаю HDD WD5000LPLX (WD Black, NTFS). На HDD три раздела - один системный загрузочный Win10, второй подкачка Win10, третий с пользовательскими папками. Два первых монтируются, третий - плашка "Неизвестная ошибка"
Взял второй HDD (SiliconPower в противоударном чехле, внутри - HDD от Samsung). Проверил - всё норм, всё монтируется, всё видится. Разобрал корпус, поменял диск на SSD, подключил - SSD определился. Монтировать в систему - выскочила плашка "Неизвестная ошибка". Вернул на место родной HDD - перестал монтироваться, выскакивает плашка "Неизвестная ошибка"
Установил Testdisk, запустил (sudo testdisk). Проверил все три диска - Testdisk ФС видит, определяет, файлы видит, можно сохранить копию. Файлы не битые - всё норм. Диски при этом не восстанавливаются - пытался восстановить ФС (Раздел - основной, загрузочный -> Write) - без изменений. При монтировании дисков - "Неизвестная ошибка".
Под руками был ещё один SSD, поднял на нём KALI (что нашлось под рукой + дистр стабильно работает на моём железе). Попробовал смонтировать диски - картина не изменилась, "Неизвестная ошибка".
ОС диски видит, корректно определяет. Смонтировать не может.
Вопрос: сталкивался кто с подобной проблемой? Я не исключаю, что проблема "железная". Сломался один диск - утянул за собой остальные (Silicon нормально работал до экспериментов). Можно решить, не трогая данных?
Для себя решил, что позднее данные сниму со всех дисков (Testdisk в помощь), перенесу на новый (желаю приобрести внешний, терабайта на 2 - 4). Потом попробую удалить разделы и записать диски заново.
Смущает WD Black. На одном носителе два раздела нормально читаются. Возможно, проблема в MBR - тогда почему Testdisk не восстанавливает? Была бы проблема с контроллером SATA или адаптером SATA-USB - тогда бы WD Black полностью не читался, как остальные. А тут два раздела в норме, монтируются как ни в чём не бывало.
В идеале - хотелось бы избежать незапланированных трат на новый внешний и конечно же - сохранить данные (бэкапы там, фотки семейные лет за 15, библиотека и прочая херня). Сидеть опять же, сохранять всё это на новое хранилище - та ещё нудятина.
Кто знает - за каким плечом нужно какими пальцами щёлкнуть, чтобы всё заработало по мановению волшебной палочки? (Юмор).
  • Вопрос задан
  • 116 просмотров
Пригласить эксперта
Ответы на вопрос 1
pindschik
@pindschik
ФЫВА ОЛДЖ
Проверьте состояние диска в CristalDiskInfo или любой другой программой, которая умеет смотреть SMART.
К сожалению на дисках ошибки случаются. И сами они ломаются. Увы.
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы