Как запусить Steam на ubuntu 22.04?

Я установил чистый ubuntu 22.04 минимальной установкой, apt update && apt upgrade по привычке сделал подождал, потом написал dpkg - - add-architecture, Потом сразу начал устанавливать Steam. Первый раз я пытался через apt-get install steam, второй раз я скачал deb и через apt install steam.deb (Были предложения установить так : dpkg steam.deb, но оно чет не работало). Steam установлен, я запускаю и выводятся такие ошибки

Steam needs to install these additional packages:
libc6:amd64 libc6:i386 libegl1:amd64 libegl1:i386 libgbm1:amd64 libgbm1:i386 libgl1-mesa-dri:amd64 libgl1-mesa-dri:i386 libgl1:amd64 libgl1:i386 steam-libs-amd64:amd64 steam-libs-i386:i386

Press return to proceed with the installation:
........W: Не удалось получить https://repo.steampowered.com/steam/dists/stable/I... Не удалось соединиться с repo.steampowered.com:443 (104.17.242.61). - connect (111: В соединении отказано) Невозможно инициализировать соединение с repo.steampowered.com:443 (2606:4700::6811:f23d). - connect (101: Сеть недоступна) Не удалось соединиться с repo.steampowered.com:443 (104.17.243.61). - connect (111: В соединении отказано) Невозможно инициализировать соединение с repo.steampowered.com:443 (2606:4700::6811:f33d). - connect (101: Сеть недоступна)
W: Некоторые индексные файлы скачать не удалось. Они были проигнорированы, или вместо них были использованы старые версии.

Чтение списков пакетов… Готово
Построение дерева зависимостей… Готово
Чтение информации о состоянии… Готово
Уже установлен пакет libegl1 самой новой версии (1.4.0-1).
libegl1 помечен как установленный вручную.
Уже установлен пакет libgl1 самой новой версии (1.4.0-1).
libgl1 помечен как установленный вручную.
Уже установлен пакет libc6 самой новой версии (2.35-0ubuntu3.1).
libc6 помечен как установленный вручную.
Уже установлен пакет libgbm1 самой новой версии (22.2.5-0ubuntu0.1~22.04.3).
libgbm1 помечен как установленный вручную.
Уже установлен пакет libgl1-mesa-dri самой новой версии (22.2.5-0ubuntu0.1~22.04.3).
libgl1-mesa-dri помечен как установленный вручную.
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
apt : Зависит: libapt-pkg6.0 (>= 2.4.9) но он не будет установлен
init : Предзависит: systemd-sysv
libc6 : Рекомендует: libnss-nis но он не будет установлен
Рекомендует: libnss-nisplus но он не будет установлен
Ломает: libc6:i386 (!= 2.35-0ubuntu3.1) но 2.35-0ubuntu3 должен быть установлен
libc6:i386 : Рекомендует: libnss-nis:i386 но он не будет установлен
Рекомендует: libnss-nisplus:i386 но он не будет установлен
Ломает: libc6 (!= 2.35-0ubuntu3) но 2.35-0ubuntu3.1 должен быть установлен
libegl1:i386 : Зависит: libegl-mesa0:i386 но он не может быть установлен
libgbm1 : Ломает: libgbm1:i386 (!= 22.2.5-0ubuntu0.1~22.04.3) но 22.0.1-1ubuntu2 должен быть установлен
libgbm1:i386 : Зависит: libdrm2:i386 (>= 2.4.75) но он не может быть установлен
Ломает: libgbm1 (!= 22.0.1-1ubuntu2) но 22.2.5-0ubuntu0.1~22.04.3 должен быть установлен
libgl1-mesa-dri : Ломает: libgl1-mesa-dri:i386 (!= 22.2.5-0ubuntu0.1~22.04.3) но 22.0.1-1ubuntu2 должен быть установлен
libgl1-mesa-dri:i386 : Зависит: libdrm-amdgpu1:i386 (>= 2.4.105) но он не может быть установлен
Зависит: libdrm-nouveau2:i386 (>= 2.4.66) но он не может быть установлен
Зависит: libdrm-radeon1:i386 (>= 2.4.31) но он не может быть установлен
Зависит: libdrm2:i386 (>= 2.4.75) но он не может быть установлен
Зависит: libglapi-mesa:i386 (= 22.0.1-1ubuntu2) но он не может быть установлен
Рекомендует: libgl1-amber-dri:i386 но он не может быть установлен
Ломает: libgl1-mesa-dri (!= 22.0.1-1ubuntu2) но 22.2.5-0ubuntu0.1~22.04.3 должен быть установлен
libglx0:i386 : Зависит: libglx-mesa0:i386 но он не может быть установлен
shim-signed : Зависит: grub-efi-amd64-signed (>= 1.187.2~) но он не будет установлен или
grub-efi-arm64-signed (>= 1.187.2~) но он не может быть установлен
Зависит: grub2-common (>= 2.04-1ubuntu24)
steam-libs-amd64 : Зависит: libudev1 но он не может быть установлен или
libudev0 но он не будет установлен
util-linux : Предзависит: libudev1 (>= 183) но он не может быть установлен
E: Ошибка: pkgProblemResolver::Resolve привёл к появлению сломанных пакетов. Это может быть вызвано зафиксированными пакетами.

Press return to continue:

После окончания вверхнего выводит окно с ошибкой:

You are missing the following 32-bit libraries, and Steam may not run:
libc.so.6

У меня уже нервы не выдерживают поэтому прошу вас о помощи, в просторах интернета такая же ошибка игнорируется или осуждается тем что автор не использовал apt-get install -f и типа такого full install например или dpkg - - add-architecture i386.
  • Вопрос задан
  • 598 просмотров
Пригласить эксперта
Ответы на вопрос 1
@rPman
Не удалось получить https://repo.steampowered.com/steam/dists/stable/I... Не удалось соединиться с repo.steampowered.com:443 (104.17.242.61). - connect (111: В соединении отказано) Невозможно инициализировать соединение с repo.steampowered.com:443 (2606:4700::6811:f23d). - connect (101: Сеть недоступна)
разберись со своим провайдером или настрой vpn/proxy туда где проблем с соединениями нет
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы