@lisonok10

Ошибка возникающая при сборке maven проекта. Какую версию Java необходимо указать?

Коллеги добрый день, использую мавен версии 3.6.3.
Java version: 11.0.17, vendor: Ubuntu, runtime: /usr/lib/jvm/java-11-openjdk-amd64.

В pom.xml файле указываю плагин maven-compiler-plugin
Его версия 3.10.1.

В конфиге плагина прописываю

<configuration>
<source>16</source>
<target>16</target>
<encoding>UTF-8</encoding>
</configuration>


В качестве родительского pom выступает spring-boot-starter-parent
Версии 2.7.9.

Выпадает ошибка при компиляции проекта:
error: invalid target release: 16

Как это починить? :(
  • Вопрос задан
  • 301 просмотр
Решения вопроса 2
mayton2019
@mayton2019 Куратор тега Java
Bigdata Engineer
Вот так надо.

<properties>
    <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
    <maven.compiler.source>11</maven.compiler.source>
    <maven.compiler.target>11</maven.compiler.target>
  </properties>

        <plugin>
          <artifactId>maven-compiler-plugin</artifactId>
          <version>3.8.0</version>
        </plugin>
Ответ написан
Комментировать
jaxtr
@jaxtr
JavaEE/Spring-разработчик
Судя по настройкам плагина ожидается, что исходный код (source) должен соответствовать Java 16 и должен компилироваться в байткод Java 16 (target). Локально установлена JDK 11, следовательно source и target могут иметь максимальное значение 11 (не получится собрать проект, написанный на Java 16, под JDK 11). Установи JDK 16+, либо установи значение 11 для свойств source и target.
Ответ написан
Комментировать
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
Bell Integrator Ульяновск
До 400 000 ₽
Bell Integrator Ижевск
До 400 000 ₽
Bell Integrator Хабаровск
До 400 000 ₽
16 июн. 2024, в 22:40
5000 руб./за проект
16 июн. 2024, в 22:17
30000 руб./за проект