@Dvach
Генератор тупых вопросов и ещё более тупых ответов

Есть ли возможность обновления только mod_ssl.so?

Дано: Debian который лет пять уже не поддерживается, а точнее Debian 6 squeeze. На нём поживает apache 2.2.16. Apache не умеет в TLS выше 1.0 (который безбожно древен и устарел как танкопарк советской армии в 1939). Нужно перебросить сайт на TLS 1.2 Без изменения версии ОС и без обновления apache, т.е. обновить только библиотеку mod_ssl.so - есть ли возможность как это сделать?
  • Вопрос задан
  • 42 просмотра
Пригласить эксперта
Ответы на вопрос 2
karabanov
@karabanov
Системный администратор
Запусти свежий apache в docker. Я так на днях MySQL 8 на старый сервер устанавливал.

Одну библиотеку не обновить - возникнет dependency hell, к тому же библиотека должна бить собрана под конкретную версию apache
Ответ написан
Комментировать
Можно развернуть рядом nginx в режиме реверс прокси, а апач перевести на с https на http с доступом только для локалхоста (или доверенного хоста, если nginx будет на отдельном сервере). Но сборка nginx для Debian 6 может быть отдельной проблемой.
P.S. Почему сервер нельзя обновить?
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы