Пытаюсь наладить «АвтоПостинг» из Wordpress(Плагин SNAP|AutoPoster) в группу(vk.com), В чём проблема?

В логах запись:
| WHERE (flt = "snap" OR (flt = "cron" AND (type = "E" OR type="W"))) |
[2021-09-13 17:46:56] [User ID:1] - [Error] [VK.Com - VK.Com #0] - -=ERROR=- Array ( [pgID] => [isPosted] => 0 [pDate] => 2021-09-13 14:46:56 [Error] => Error: Array ( [headers] => Array ( [server] => kittenx [date] => Mon, 13 Sep 2021 14:46:56 GMT [content-type] => application/json; charset=utf-8 [content-length] => 312 [connection] => keep-alive [x-powered-by] => KPHP/7.4.108562 [set-cookie] => remixir=DELETED; expires=Thu, 01 Jan 1970 00:00:01 GMT; path=/; domain=.vk.com; secure; HttpOnly [cache-control] => no-store [x-frame-options] => DENY [content-encoding] => gzip ) [body] => {"error":{"error_code":8,"error_msg":"Invalid request: versions below 5.81 are deprecated. Version param should be passed as \"v\". \"version\" param is invalid and not supported. For more information go to https:\/\/vk.com\/dev\/constant_version_updates","request_params":[{"key":"v","value":"5.71"},{"key":"method","value":"wall.post"},{"key":"oauth","value":"1"},{"key":"owner_id","value":"-0"},{"key":"from_group","value":"1"},{"key":"message","value":"Тест 6Тест 6Тест 6"},{"key":"attachments","value":""}]}} [response] => Array ( [code] => 200 [message] => OK ) [cookies] => Array ( [0] => nxs_Http_Cookie Object ( [name] => remixir [value] => DELETED [expires] => 1 [path] => / [domain] => .vk.com [secure] => [httponly] => ) ) ) ) Тест 6

Вижу тут "error_msg": Invalid request: versions below 5.81 are deprecated. Version param should be passed as \"v\". \"version\" param is invalid and not supported. For more information go to https:\/\/vk.com\/dev\/constant_version_updates

Можно более понятным языком: как решить проблему?
  • Вопрос задан
  • 1191 просмотр
Пригласить эксперта
Ответы на вопрос 2
@wa-user
тС 47911 - я решил временно проблему так - в файле vk.api.php (wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/inc-cl) - заменил все 5.7 (может быть другая цифра) на 5.107 - все заработало...
Ответ написан
@Fruktuz
Столкнулся с той же проблемой, но в плагине Easy Vkontakte Connect.
Vk обновил API и плагин со вчерашнего дня перестал работать. В логах следующее: VK Error. 8 Invalid request: versions below 5.81 are deprecated.
Если кто-то решил проблему - помогите, пожалуйста.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы