@kinojs
Начинающий разрабочтик, WEB

Как установить пакет более старой версии (Ubuntu)?

Я пытаюсь поставить gcc версии 7.3.0, потому что на версии 7.5.0 (новейшая для gcc-7) не компилируется пакет, который я пытаюсь установить.

Я получил список версиий пакета с помощью этой команды

apt-cache policy gcc-7

Вывело

Version table:
     7.5.0-3ubuntu1~18.04 500
        500 http://mirror.yandex.ru/ubuntu bionic-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
     7.3.0-16ubuntu3 500
        500 http://mirror.yandex.ru/ubuntu bionic/main amd64 Packages


Пытаюсь поставить 7.3.0

sudo apt-get install gcc-7=7.3.0-16ubuntu3

Но получаю ошибку

The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gcc-7 : Depends: cpp-7 (= 7.3.0-16ubuntu3) but 7.5.0-3ubuntu1~18.04 is to be installed
         Depends: gcc-7-base (= 7.3.0-16ubuntu3) but 7.5.0-3ubuntu1~18.04 is to be installed
         Depends: libgcc-7-dev (= 7.3.0-16ubuntu3) but 7.5.0-3ubuntu1~18.04 is to be installed
         Recommends: libc6-dev (>= 2.13-0ubuntu6) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


Как быть?
  • Вопрос задан
  • 70 просмотров
Решения вопроса 1
karabanov
@karabanov
Системный администратор
Можно конечно повозиться, но этот dependency hell разгребать совсем не весело.
Есть Docker контейнер с GCC собери в нём, что тебе там надо собрать.
Ответ написан
Пригласить эксперта
Ответы на вопрос 1
Можно в Терминале скачивать нужный пакет принудительно с реп Ubuntu, устанавливать его и на сообщение о зависимостях выполнить в нём же исправление данной траблы, но!!!

Ты пытаешься установить пакет не для стандартной архитектуры.
Обрати внимание на данный пакет.
Для каких он архитектур.
60ffbe8a4fc0d783762361.png

А именно только для:
arm64
armhf
ppc64el
s390x


Но никак не для amd64 и i386!!!
И других вариантов просто нет!

Поэтому устанавливай пакет или просто набрав:
sudo apt install gcc-7
без каких-либо хвостов для др. архитектур и система сама установить то, что ей надо...

Либо, если версия не подходит, ищи версию, коя подходит, качай принудительно с реп, как выше я писал.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы